Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSascha Silbe <silbe@buildslave-debian-squeeze-64bit.sugarlabs.org>2010-06-13 17:30:31 (GMT)
committer Sascha Silbe <silbe@buildslave-debian-squeeze-64bit.sugarlabs.org>2010-06-13 17:30:31 (GMT)
commit031d06f6fe8a44116487c22f77d2c5dbde414aff (patch)
tree214110083fe8216d70f3801c0e4f329329b610a3
parent75e046dde49c6e281dd3b3fa31945c22a903cbe9 (diff)
regenerate autofoo during build
-rwxr-xr-xbuild-snapshots8
1 files changed, 8 insertions, 0 deletions
diff --git a/build-snapshots b/build-snapshots
index 031d9fa..2f678db 100755
--- a/build-snapshots
+++ b/build-snapshots
@@ -39,6 +39,14 @@ gen_and_import_tarball() {
}
build() {
+ if [ -x autogen.sh ] ; then
+ ./autogen.sh
+ else
+ grep -q IT_PROG_INTLTOOL configure.ac && intltoolize -c
+ autoreconf -i
+ automake
+ fi
+ git commit -a -m "regenerate autofoo"
git-buildpackage --git-builder="pdebuild --configfile ${MYDIR}/pbuilderrc --debbuildopts '-I.git -i\.git'" --git-cleaner="fakeroot debian/rules clean" --git-no-pristine-tar --git-export-dir=../build
}