Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSascha Silbe <silbe@buildslave-debian-squeeze-32bit.sugarlabs.org>2010-07-14 15:19:49 (GMT)
committer Sascha Silbe <silbe@buildslave-debian-squeeze-32bit.sugarlabs.org>2010-07-14 15:32:25 (GMT)
commit6acf5b9d91010985cf5adc30ff611a34a3a36469 (patch)
tree2aba974b01d24a3b56b31562f1c780be24456456
parentd5d4173213e477ec1f4a82ed8f60686f9d29ac9e (diff)
move autofoo regeneration to a separate step and only commit if it actually changed something
-rwxr-xr-xbuild-snapshots10
1 files changed, 8 insertions, 2 deletions
diff --git a/build-snapshots b/build-snapshots
index 1899224..5ecd327 100755
--- a/build-snapshots
+++ b/build-snapshots
@@ -36,7 +36,7 @@ gen_and_import_tarball() {
git-import-orig "${package}-${version}".tar.gz
}
-build() {
+autoregen() {
if [ -x autogen.sh ] ; then
./autogen.sh
else
@@ -44,7 +44,12 @@ build() {
autoreconf -i
automake
fi
- git commit -a -m "regenerate autofoo"
+ if [ -n "$(git status --porcelain --untracked-files=no)" ] ; then
+ git commit -a -m "regenerate autofoo"
+ fi
+}
+
+build() {
git-buildpackage --git-builder="pdebuild --configfile ${MYDIR}/pbuilderrc --debbuildopts '-I.git -i\.git'" --git-cleaner="fakeroot debian/rules clean" --git-no-pristine-tar --git-export-dir=../build
}
@@ -68,6 +73,7 @@ for package in sugar sugar-artwork sugar-base sugar-datastore sugar-presence-ser
set -e
package_apply "${package}" repo_clean
package_apply "${package}" repo_update
+ package_apply "${package}" autoregen
package_apply "${package}" version_set
package_apply "${package}" build
# package_apply "${package}" upload