Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSascha Silbe <silbe@buildslave-debian-squeeze-64bit.sugarlabs.org>2010-07-27 10:56:53 (GMT)
committer Sascha Silbe <silbe@buildslave-debian-squeeze-64bit.sugarlabs.org>2010-07-27 10:56:53 (GMT)
commitd5322a9c68390e5f6ecc09c8c1425f07771c90ff (patch)
tree8c86405e7fa7f2a46bd9618c6aebb0871e19e89d
parent28d120379dedb0047c7fbca252571f840f3b1d88 (diff)
fixed automatic merge of Debian packaging changes
-rwxr-xr-xbuild-snapshots13
-rwxr-xr-xsetup-snapshots12
2 files changed, 23 insertions, 2 deletions
diff --git a/build-snapshots b/build-snapshots
index 9d16304..171f9e9 100755
--- a/build-snapshots
+++ b/build-snapshots
@@ -21,12 +21,21 @@ repo_update() {
append_git_changelog() {
local range="${1}"
- git log --no-merges --pretty=format:'[%h] %s (%an)' "${range}" |xargs -L 1 -d '\n' --no-run-if-empty dch
+ git log --no-merges --pretty=format:'[%h] %s (%an)' "${range}" |xargs -L 1 -d '\n' --no-run-if-empty dch --no-auto-nmu --no-multimaint
}
version_set() {
local upstream_version="$(git tag|grep ^v|tr -d v|sort -t . -n|tail -n 1)"
- dch --newversion "${upstream_version}-git$(date +%Y%m%d)-1" --preserve --distribution testing "Nightly snapshot package"
+ local pkg_name="$(grep ^Source: debian/control.in |head -n 1 |sed -e 's/^Source: *//')"
+ cat - debian/changelog > debian/changelog.tmp << EOT
+${pkg_name} (${upstream_version}-git$(date +%Y%m%d)-1) testing; urgency=low
+
+ * Nightly snapshot package
+
+ -- maintainer <foo@bar.com> $(date -R)
+
+EOT
+ mv debian/changelog.tmp debian/changelog
append_git_changelog pre-merge..master
git commit -m "Add changelog entry for nightly snapshot build" debian/changelog
}
diff --git a/setup-snapshots b/setup-snapshots
index 11eb408..cd9d8a1 100755
--- a/setup-snapshots
+++ b/setup-snapshots
@@ -10,6 +10,18 @@ for package in sugar sugar-artwork sugar-base sugar-datastore sugar-presence-ser
# git branch upstream upstream/master
git branch upstream origin/upstream
debian/rules get-orig-source
+ git config merge.dpkg-mergechangelogs.name "debian/changelog merge driver"
+ git config merge.dpkg-mergechangelogs.driver "dpkg-mergechangelogs -m %O %A %B %A"
+ git config merge.ours.name "Always use 'our' side"
+ git config merge.ours.driver "true"
+ cat >> .gitattributes << EOT
+debian/changelog merge=dpkg-mergechangelogs
+configure merge=ours
+aclocal.m4 merge=ours
+Makefile.in merge=ours
+EOT
+ git add .gitattributes
+ git commit -m "set merge drivers for debian/changelog and auto* files"
cd ..
done