Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSascha Silbe <silbe@buildslave-debian-squeeze-32bit.sugarlabs.org>2010-07-14 15:19:49 (GMT)
committer Sascha Silbe <silbe@buildslave-debian-squeeze-32bit.sugarlabs.org>2010-07-14 15:32:16 (GMT)
commitd5d4173213e477ec1f4a82ed8f60686f9d29ac9e (patch)
treea3ee9e57980a223d61299c7f609385c36bca115c
parent031d06f6fe8a44116487c22f77d2c5dbde414aff (diff)
Don't use reset so we can show the differences between nightly builds in the changelog
-rwxr-xr-xbuild-snapshots6
1 files changed, 2 insertions, 4 deletions
diff --git a/build-snapshots b/build-snapshots
index 2f678db..1899224 100755
--- a/build-snapshots
+++ b/build-snapshots
@@ -8,22 +8,20 @@ repo_update() {
git fetch origin
git fetch upstream
git checkout upstream
- git reset --hard origin/upstream
git merge upstream/master
git checkout master
- git reset --hard origin/master
git merge upstream
}
append_git_changelog() {
local range="${1}"
- git log --pretty=format:'[%h] %s (%an)' "${range}" |xargs -L 1 --no-run-if-empty dch
+ git log --no-merges --pretty=format:'[%h] %s (%an)' "${range}" |xargs -L 1 --no-run-if-empty dch
}
version_set() {
local upstream_version="$(git tag|grep ^v|tr -d v|sort -t . -n|tail -n 1)"
dch --newversion "${upstream_version}-git$(date +%Y%m%d)-1" --preserve --distribution testing "Nightly snapshot package"
- append_git_changelog origin/master..upstream/master
+ append_git_changelog master^..master
git commit -m "Add changelog entry for nightly snapshot build" debian/changelog
}