Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2009-09-21 18:35:21 (GMT)
committer Carlos Garcia Campos <carlosgc@gnome.org>2009-09-22 08:10:31 (GMT)
commit2a5ce34fce3f7ab37587b644a3f4a961204cd504 (patch)
treeda4ed25c4fb4ce639683fa8afc81212aa43c6830 /Makefile.am
parentb790da7f9d8ced041675df7458bc78eea0f3ddbd (diff)
[build] Add --disable-tests to disable tests during distcheck
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 7030b1b..011d1fc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,8 +8,11 @@ SUBDIRS = \
properties \
shell \
po \
- help \
- test
+ help
+
+if ENABLE_TESTS
+SUBDIRS += test
+endif
if ENABLE_THUMBNAILER
SUBDIRS += thumbnailer
@@ -52,7 +55,7 @@ DISTCLEANFILES = \
ACLOCAL_AMFLAGS = -I m4
-DISTCHECK_CONFIGURE_FLAGS = --disable-schemas-install --disable-scrollkeeper --enable-gtk-doc --disable-nautilus
+DISTCHECK_CONFIGURE_FLAGS = --disable-schemas-install --disable-scrollkeeper --enable-gtk-doc --disable-nautilus --disable-tests
# Ignore scrollkeeper issues for now. @#*$& scrollkeeper
distuninstallcheck_listfiles = find . -type f -print | grep -v scrollkeeper | grep -v /share/gnome/help/ | grep -v \.omf