Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/backend/Makefile.am
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <mpg@redhat.com>2005-07-05 15:31:17 (GMT)
committer Marco Pesenti Gritti <marco@src.gnome.org>2005-07-05 15:31:17 (GMT)
commit4684716c489657edf098565eb54bdf86bad1b45c (patch)
tree8e415778063a717a11dc09fa61042a603ff34b37 /backend/Makefile.am
parent26a8622fe284cd0e4531caa56f918d7cfaf8037b (diff)
Rework document types managing to avoid code duplication and actually
2005-07-05 Marco Pesenti Gritti <mpg@redhat.com> * backend/Makefile.am: * backend/ev-document-factory.c: (mime_type_supported_by_gdk_pixbuf), (ev_document_type_get_from_mime), (ev_document_factory_get_document), (ev_document_factory_get_backend), (ev_document_factory_get_mime_types), (ev_document_factory_get_all_mime_types): * backend/ev-document-factory.h: * shell/Makefile.am: * shell/ev-document-types.c: (get_document_from_uri), (ev_document_types_get_document), (file_filter_add_mime_list_and_free), (ev_document_types_add_filters): * shell/ev-document-types.h: * shell/ev-job-xfer.c: (ev_job_xfer_run): * shell/ev-properties-dialog.c: (ev_properties_dialog_set_document): * shell/ev-window.c: (ev_window_cmd_file_open), (ev_window_cmd_save_as): * thumbnailer/evince-thumbnailer.c: (evince_thumbnail_pngenc_get): Rework document types managing to avoid code duplication and actually abstract from backend implementations. Also provide a minimal factory api that can be used by thumbnailer/properties.
Diffstat (limited to 'backend/Makefile.am')
-rw-r--r--backend/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/backend/Makefile.am b/backend/Makefile.am
index 8ce117d..3597186 100644
--- a/backend/Makefile.am
+++ b/backend/Makefile.am
@@ -3,6 +3,12 @@ NULL=
INCLUDES= \
-DEVINCE_UIDIR=\"$(pkgdatadir)\" \
-DGNOMELOCALEDIR=\"$(datadir)/locale\" \
+ -I$(top_srcdir)/pdf \
+ -I$(top_srcdir)/pixbuf \
+ -I$(top_srcdir)/tiff \
+ -I$(top_srcdir)/ps \
+ -I$(top_srcdir)/djvu \
+ -I$(top_srcdir)/dvi \
$(SHELL_CFLAGS) \
$(EVINCE_DISABLE_DEPRECATED) \
$(NULL)
@@ -17,6 +23,8 @@ libevbackend_la_SOURCES= \
ev-link.h \
ev-document.c \
ev-document.h \
+ ev-document-factory.c \
+ ev-document-factory.h \
ev-document-thumbnails.c \
ev-document-thumbnails.h \
ev-document-fonts.c \