Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/backend/Makefile.am
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2006-12-27 17:33:22 (GMT)
committer Carlos Garcia Campos <carlosgc@src.gnome.org>2006-12-27 17:33:22 (GMT)
commitf7c3085a0e3c5c813cf9ae40b55fd7390e9373e2 (patch)
tree0e54d7c36a9dc4393056f67cc14061a58aceeff1 /backend/Makefile.am
parente9b31a6dcb17880596c0fab43d606294ffc5c17b (diff)
Add page transition support in presentation mode. At the moment only page
2006-12-27 Carlos Garcia Campos <carlosgc@gnome.org> * configure.ac: * backend/Makefile.am: * backend/ev-document-transition.[ch]: * pdf/ev-poppler.cc: (pdf_document_get_page_duration), (pdf_document_page_transition_iface_init): * shell/ev-view-private.h: * shell/ev-view.c: (ev_view_destroy), (page_changed_cb), (ev_view_set_presentation), (transition_next_page), (ev_view_presentation_transition_stop), (ev_view_presentation_transition_start), (ev_view_next_page): Add page transition support in presentation mode. At the moment only page duration is supported, but not transition effects. Fixes bug #309815.
Diffstat (limited to 'backend/Makefile.am')
-rw-r--r--backend/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/backend/Makefile.am b/backend/Makefile.am
index 2de2f5f..54dbd2c 100644
--- a/backend/Makefile.am
+++ b/backend/Makefile.am
@@ -43,6 +43,8 @@ libevbackend_la_SOURCES= \
ev-document-find.c \
ev-document-find.h \
ev-document-info.h \
+ ev-document-transition.h \
+ ev-document-transition.c \
ev-file-exporter.c \
ev-file-exporter.h \
ev-render-context.h \