Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/backend/pdf/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@gnome.org>2009-08-16 20:04:25 (GMT)
committer Christian Persch <chpe@gnome.org>2009-08-16 20:04:25 (GMT)
commit6928d325b767871772a9abd86e91456bcceb405a (patch)
treeac190fd90a9bf8f58bfa5b0f7d0d8160f0a517d8 /backend/pdf/Makefile.am
parent3f7764002b149ab5052e1a9a55300bc9c8393062 (diff)
Add EV_INTLTOOL_EVINCE_BACKEND_RULE
Create a rule for the .evince-backend file creation, and use that one instead of hardcoding it in every Makefile.am. Use $(AM_V_GEN) in the rule.
Diffstat (limited to 'backend/pdf/Makefile.am')
-rw-r--r--backend/pdf/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/backend/pdf/Makefile.am b/backend/pdf/Makefile.am
index 34103e6..1d2115a 100644
--- a/backend/pdf/Makefile.am
+++ b/backend/pdf/Makefile.am
@@ -23,11 +23,10 @@ libpdfdocument_la_LIBADD = \
$(CAIRO_PS_LIBS)
backend_in_files = pdfdocument.evince-backend.in
-
-%.evince-backend: %.evince-backend.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*po) ; $(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
-
backend_DATA = $(backend_in_files:.evince-backend.in=.evince-backend)
EXTRA_DIST = $(backend_in_files)
CLEANFILES = $(backend_DATA)
+
+@EV_INTLTOOL_EVINCE_BACKEND_RULE@