Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2007-06-02 09:00:49 (GMT)
committer Carlos Garcia Campos <carlosgc@src.gnome.org>2007-06-02 09:00:49 (GMT)
commit2fa78c4d755162b65978c1de43568742d075935a (patch)
tree3de8840a18d44ac7d07b65a20a10c0da0e131495 /configure.ac
parentc500456e3448832c7fc0f4436fe5a335b4afca5c (diff)
Bump requirements to poppler 0.5.9 and drop all ifdefs used.
2007-06-02 Carlos Garcia Campos <carlosgc@gnome.org> * configure.ac: * backend/pdf/ev-poppler.cc: (pdf_document_images_get_images), (pdf_selection_render_selection), (pdf_document_get_page_duration): Bump requirements to poppler 0.5.9 and drop all ifdefs used. svn path=/trunk/; revision=2482
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index ce14c57..391f0f6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -235,7 +235,7 @@ AC_ARG_ENABLE(pdf,
[AC_HELP_STRING([--enable-pdf], [Compile with pdf support])],enable_pdf="$enableval",enable_pdf=yes)
if test "x$enable_pdf" = "xyes"; then
- POPPLER_REQUIRED=0.5.4
+ POPPLER_REQUIRED=0.5.9
PKG_CHECK_MODULES(POPPLER, poppler-glib >= $POPPLER_REQUIRED,enable_pdf=yes,enable_pdf=no)
if test "x$enable_pdf" = "xyes"; then
@@ -247,9 +247,6 @@ if test "x$enable_pdf" = "xyes"; then
evince_save_LIBS=$LIBS
LIBS="$LIBS $FRONTEND_LIBS"
AC_CHECK_FUNCS(poppler_page_render)
- AC_CHECK_FUNCS(poppler_page_get_duration)
- AC_CHECK_FUNCS(poppler_page_get_image_mapping)
- AC_CHECK_FUNCS(poppler_page_render_selection_to_pixbuf)
LIBS=$evince_save_LIBS
PKG_CHECK_MODULES(CAIRO_PDF, cairo-pdf, enable_cairo_pdf=yes, enable_cairo_pdf=no)