Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNickolay V. Shmyrev <nshmyrev@src.gnome.org>2005-05-21 11:46:37 (GMT)
committer Nickolay V. Shmyrev <nshmyrev@src.gnome.org>2005-05-21 11:46:37 (GMT)
commit3294f7102500ef787ffd0314c95bfe59c0c9a6bf (patch)
tree4ed75791ac2ea218487f4a3758e90084779ae4bf /configure.ac
parente533ab12f74d16805e0d9a984f9f6383ab5d7bc6 (diff)
Conditionally add dvi and djvu mime types to desktop file. Fix for 304658
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 93c9db9..4d9f0c0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -164,6 +164,18 @@ AM_CONDITIONAL(WITH_TYPE1_FONTS, test x$enable_type1_fonts = xyes)
dnl ================== End of dvi checks ===================================================
+dnl =================== Mime types list ====================================================
+
+EVINCE_MIME_TYPES="application/pdf;application/postscript;application/x-gzpostscript"
+
+if test "x$enable_dvi" = "xyes"; then
+ EVINCE_MIME_TYPES="$EVINCE_MIME_TYPES;application/x-dvi"
+fi
+if test "x$enable_djvu" = "xyes"; then
+ EVINCE_MIME_TYPES="$EVINCE_MIME_TYPES;image/vnd.djvu"
+fi
+AC_SUBST(EVINCE_MIME_TYPES)
+
dnl Turn on the additional warnings last, so -Werror doesn't affect other tests.
dnl stolen from nautilus and gnome-common
@@ -216,7 +228,6 @@ else
AC_MSG_RESULT(no)
fi
-
AC_OUTPUT([
Makefile
cut-n-paste/Makefile
@@ -224,6 +235,7 @@ cut-n-paste/recent-files/Makefile
cut-n-paste/zoom-control/Makefile
cut-n-paste/toolbar-editor/Makefile
data/Makefile
+data/evince.desktop.in
lib/Makefile
pdf/Makefile
pixbuf/Makefile