Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNickolay V. Shmyrev <nshmyrev@src.gnome.org>2006-05-13 03:54:09 (GMT)
committer Nickolay V. Shmyrev <nshmyrev@src.gnome.org>2006-05-13 03:54:09 (GMT)
commit70f641411b2fbab930b481ac844984819b48805d (patch)
tree9a5f411c0aed9a4ab71e8eb7ce4d32cbf0735b89 /configure.ac
parentf222d19fbbd936de7f403eb29666b41e3447b48d (diff)
Bump requirements to gtk 2.8 and drop all idfefs used.
* configure.ac: * properties/ev-properties-main.c: (ev_properties_get_pages): * shell/ev-application.c: (ev_application_open_window), (ev_application_open_uri_at_dest): * shell/ev-sidebar-attachments.c: (ev_sidebar_attachments_init): * shell/ev-sidebar-thumbnails.c: (adjustment_changed_cb), (ev_sidebar_thumbnails_use_icon_view), (page_changed_cb): * shell/ev-utils.c: (save_print_config_to_file): * shell/ev-window.c: (ev_window_cmd_save_as), (ev_attachment_popup_cmd_save_attachment_as): * shell/main.c: (load_files_remote): Bump requirements to gtk 2.8 and drop all idfefs used.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 3 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index e670809..256a871 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,9 +43,10 @@ dnl Check dependencies
POPPLER_REQUIRED=0.5.1
DBUS_GLIB_REQUIRED=0.33
-GTK_REQUIRED=2.6.0
-LIBGNOMEUI_REQUIRED=2.6.0
+GTK_REQUIRED=2.8.15
KEYRING_REQUIRED=0.4.0
+
+LIBGNOMEUI_REQUIRED=2.6.0
LIBGNOMEPRINTUI_REQUIRED=2.5.1
PKG_CHECK_MODULES(LIB, gtk+-2.0 >= $GTK_REQUIRED libgnomeui-2.0 >= $LIBGNOMEUI_REQUIRED)
@@ -137,16 +138,6 @@ if test x$HAVE_NAUTILUS = "xyes"; then
fi
AM_CONDITIONAL(HAVE_NAUTILUS, test x$HAVE_NAUTILUS = "xyes")
-dnl Check for functions not present in gtk 2.6
-evince_save_LIBS=$LIBS
-LIBS="$LIBS $FRONTEND_CORE_LIBS"
-AC_CHECK_FUNCS(gtk_icon_view_get_visible_range)
-AC_CHECK_FUNCS(gtk_window_present_with_time)
-AC_CHECK_FUNCS(g_file_set_contents)
-AC_CHECK_FUNCS(gtk_file_chooser_set_do_overwrite_confirmation)
-AC_CHECK_FUNCS(gtk_icon_view_enable_model_drag_source)
-LIBS=$evince_save_LIBS
-
dnl GConf configuration
AM_GCONF_SOURCE_2