Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2005-07-05 17:02:52 (GMT)
committer Marco Pesenti Gritti <marco@src.gnome.org>2005-07-05 17:02:52 (GMT)
commit8d858ef399ef70a2c9efb391242e8c8be70e2109 (patch)
treefaccd24d5152eb6d604bb7b7516b8121beee6db3 /configure.ac
parentffd47fa767f69c0b534037a6e067534d7d2345c9 (diff)
Marco Pesenti Gritti <mpg@redhat.com>
2005-07-05 Carlos Garcia Campos <carlosgc@gnome.org> Marco Pesenti Gritti <mpg@redhat.com> * shell/Makefile.am: Add --prefix for dbus-binding-tool script * shell/ev-application.[ch], shell/ev-window.c: change dbus RPC functions to the format required by dbus * shell/main.c: use G_TYPE instead of DBUS_TYPE to fix compilation errors. Use the RPC parameters in the expected way
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index bd56713..70084aa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,8 +59,12 @@ AC_MSG_RESULT([$enable_dbus])
if test "x$enable_dbus" = "xyes" ; then
AC_DEFINE([ENABLE_DBUS],[1],[Define if DBUS support is enabled])
- AC_DEFINE([ENABLE_METADATA],[1],[Define if metadata support is enabled])
+ AC_DEFINE([ENABLE_METADATA],[1],[Define if metadata support is enabled])
PKG_CHECK_MODULES([DBUS], [dbus-glib-1 >= $DBUS_GLIB_REQUIRED])
+
+ DBUS_VERSION=`$PKG_CONFIG --modversion dbus-glib-1 | sed 's/0.\([[0-9]]*\)/\1/'`
+ AC_DEFINE_UNQUOTED(DBUS_VERSION, $DBUS_VERSION, [DBUS version.])
+ AM_CONDITIONAL([DBUS_TOOL_NO_PREFIX], [test "x$DBUS_VERSION" = "x33"])
fi
AM_CONDITIONAL([ENABLE_DBUS], [test "x$enable_dbus" = "xyes"])