Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2008-04-12 10:39:07 (GMT)
committer Carlos Garcia Campos <carlosgc@src.gnome.org>2008-04-12 10:39:07 (GMT)
commit934e363e19992df871c1177ffa33044119e40266 (patch)
tree17f7f343008a20febc7d3620923bab4a52b2ce67 /configure.ac
parente1f8d970480e9ebce9bffecba45f6963d9e82a4f (diff)
Remove gs stuff from ps backend.
2008-04-12 Carlos Garcia Campos <carlosgc@gnome.org> * configure.ac: * backend/ps/Makefile.am: Remove gs stuff from ps backend. svn path=/trunk/; revision=3002
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 8 insertions, 25 deletions
diff --git a/configure.ac b/configure.ac
index 2b5bca1..249e7d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -238,42 +238,25 @@ fi
AM_CONDITIONAL(ENABLE_PDF, test x$enable_pdf = xyes)
dnl ================== end of pdf checks ============================================
-SPECTRE_REQUIRED=0.2.0
dnl libspectre (used by ps and dvi backends)
+SPECTRE_REQUIRED=0.2.0
PKG_CHECK_MODULES(SPECTRE, libspectre >= $SPECTRE_REQUIRED,have_spectre=yes,have_spectre=no)
AM_CONDITIONAL(HAVE_SPECTRE, test x$have_spectre = xyes)
if test "x$have_spectre" = "xyes"; then
- AC_DEFINE([HAVE_SPECTRE], [1], [Have libpectre])
+ AC_DEFINE([HAVE_SPECTRE], [1], [Have libspectre])
fi
dnl ================== ps checks ====================================================
AC_ARG_ENABLE(ps,
[AC_HELP_STRING([--disable-ps], [Compile without PostScript backend])],enable_ps=$enableval,enable_ps="yes")
-ps_backend=""
-if test x$enable_ps = xyes; then
- AC_DEFINE([ENABLE_PS], [1], [Enable support for PostScript files.])
-
- if test "x$have_spectre" = "xyes"; then
- ps_backend="(libspectre)"
+if test "x$enable_ps" = "xyes"; then
+ if test "x$have_spectre = xyes"; then
+ AC_DEFINE([ENABLE_PS], [1], [Enable support for PostScript files.])
else
- dnl check for GS version
- AC_MSG_CHECKING(for Ghostscript version...)
- GS_VERSION=`gs --version | head -n 1 | sed 's/\([[0-9]]*\)\.\([[0-9]]*\).*/\1/'`
- AC_MSG_RESULT(found $GS_VERSION)
- if test "$GS_VERSION" -lt "7"; then
- AC_MSG_WARN([PS support is disabled since libspectre (version >= $SPECTRE_REQUIRED) or Ghostscript (version >= 7) are needed])
- enable_ps=no
- else
- AC_ARG_WITH(gs-aa-params,
- [AC_HELP_STRING([--with-gs-aa-params], [Define antialiasing params for ghostscript])],AA_PARAMS=$withval,
- AA_PARMS="-sDEVICE=x11alpha -dNOPLATFONTS -dGraphicsAlphaBits=4 -dTextAlphaBits=4 -dDOINTERPOLATE"
- )
- AC_DEFINE_UNQUOTED(ALPHA_PARAMS, "$AA_PARMS", [Anti-aliasing parameters for Ghostscript.])
- AC_MSG_RESULT(Antialiasing parameters for Ghostscript: $AA_PARMS)
- ps_backend="(gs)"
- fi
+ enable_ps="no"
+ AC_MSG_WARN([PS support is disabled since libspectre (version >= $SPECTRE_REQUIRED) is needed])
fi
fi
AM_CONDITIONAL(ENABLE_PS, test x$enable_ps = xyes)
@@ -484,7 +467,7 @@ Configure summary:
Gtk-Doc Support....: $enable_gtk_doc
PDF Backend........: $enable_pdf
- PostScript Backend.: $enable_ps $ps_backend
+ PostScript Backend.: $enable_ps
TIFF Backend.......: $enable_tiff
DJVU Backend.......: $enable_djvu
DVI Backend........: $enable_dvi