Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2007-09-03 20:58:54 (GMT)
committer Carlos Garcia Campos <carlosgc@src.gnome.org>2007-09-03 20:58:54 (GMT)
commit974a49f21845900f4ea154088a17b6b7e55a27e6 (patch)
treec2af1eada2b7c46b2232e12d8244053e0f7d3a80 /configure.ac
parent62df36db729c222cf47774268a0fb83dabc8c65a (diff)
Bump requirements to poppler 0.6 and drop all ifdefs used. Double and
2007-09-03 Carlos Garcia Campos <carlosgc@gnome.org> * configure.ac: * backend/pdf/ev-poppler.cc: (pdf_selection_get_selected_text), (pdf_selection_get_selection_region), (pdf_selection_get_selection_map), (ev_form_field_from_poppler_field): Bump requirements to poppler 0.6 and drop all ifdefs used. Double and triple click selections are enabled again now. svn path=/trunk/; revision=2661
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 1 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index c6849a0..49bc4e4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -235,7 +235,7 @@ AC_ARG_ENABLE(pdf,
[AC_HELP_STRING([--enable-pdf], [Compile with pdf support])],enable_pdf="$enableval",enable_pdf=yes)
if test "x$enable_pdf" = "xyes"; then
- POPPLER_REQUIRED=0.5.9
+ POPPLER_REQUIRED=0.6
PKG_CHECK_MODULES(POPPLER, poppler-glib >= $POPPLER_REQUIRED,enable_pdf=yes,enable_pdf=no)
if test "x$enable_pdf" = "xyes"; then
@@ -247,11 +247,6 @@ if test "x$enable_pdf" = "xyes"; then
evince_save_LIBS=$LIBS
LIBS="$LIBS $FRONTEND_LIBS"
AC_CHECK_FUNCS(poppler_page_render)
- dnl we need latest poppler cvs head,
- dnl this function was the last to be added
- AC_CHECK_FUNCS(poppler_form_field_button_get_button_type)
- AC_CHECK_FUNCS(poppler_form_field_text_get_max_len)
- AC_CHECK_FUNCS(poppler_form_field_text_is_password)
LIBS=$evince_save_LIBS
PKG_CHECK_MODULES(CAIRO_PDF, cairo-pdf, enable_cairo_pdf=yes, enable_cairo_pdf=no)