Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@src.gnome.org>2009-02-08 13:11:18 (GMT)
committer Christian Persch <chpe@src.gnome.org>2009-02-08 13:11:18 (GMT)
commitdbedc68c9c3390f4f8c749daa85f685923f20e17 (patch)
treeea0148a686a68a4a0ce7ed8a97399c61e76eef85 /configure.ac
parentb16d94919e61b0228950073ade43ace80fb1e1b0 (diff)
Add experimental introspection support. Disabled by default; use
* configure.ac: * libdocument/Makefile.am: * libview/Makefile.am: Add experimental introspection support. Disabled by default; use --enable-introspection to enable it. Bug #569083. svn path=/trunk/; revision=3422
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 36 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e66b125..435e0c0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -267,6 +267,41 @@ if test "x$GCONFTOOL" = "xno"; then
AC_MSG_ERROR([gconftool-2 executable not found in your path - should be installed with GConf])
fi
+# ***
+# GIR
+# ***
+
+AC_MSG_CHECKING([whether GObject introspection is requested])
+AC_ARG_ENABLE([introspection],
+ AS_HELP_STRING([--enable-introspection],[Enable GObject introspection]),
+ [],[enable_introspection=no])
+AC_MSG_RESULT([$enable_introspection])
+
+G_IR_SCANNER=
+G_IR_COMPILER=
+G_IR_GENERATE=
+GIRDIR=
+GIRTYPELIBDIR=
+
+if test "$enable_introspection" = "yes"; then
+ GOBJECT_INTROSPECTION_REQUIRED=0.6
+ PKG_CHECK_MODULES([GOBJECT_INTROSPECTION],[gobject-introspection-1.0 >= $GOBJECT_INTROSPECTION_REQUIRED])
+
+ G_IR_SCANNER="$($PKG_CONFIG --variable=g_ir_scanner gobject-introspection-1.0)"
+ G_IR_COMPILER="$($PKG_CONFIG --variable=g_ir_compiler gobject-introspection-1.0)"
+ G_IR_GENERATE="$($PKG_CONFIG --variable=g_ir_generate gobject-introspection-1.0)"
+ GIRDIR="$($PKG_CONFIG --variable=girdir gobject-introspection-1.0)"
+ GIRTYPELIBDIR="$($PKG_CONFIG --variable=typelibdir gobject-introspection-1.0)"
+fi
+
+AC_SUBST([G_IR_SCANNER])
+AC_SUBST([G_IR_COMPILER])
+AC_SUBST([G_IR_GENERATE])
+AC_SUBST([GIRDIR])
+AC_SUBST([GIRTYPELIBDIR])
+
+AM_CONDITIONAL([ENABLE_INTROSPECTION],[test "$enable_introspection" = "yes"])
+
dnl ================== portability checks ===========================================
dnl for backtrace()
@@ -574,6 +609,7 @@ Configure summary:
Thumbnailer........: $ENABLE_THUMBNAILER
Gtk-Doc Support....: $enable_gtk_doc
Debug mode.........: $enable_debug
+ GObj. Introspection: $enable_introspection
PDF Backend........: $enable_pdf
PostScript Backend.: $enable_ps