Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2008-04-12 10:19:39 (GMT)
committer Carlos Garcia Campos <carlosgc@src.gnome.org>2008-04-12 10:19:39 (GMT)
commite1f8d970480e9ebce9bffecba45f6963d9e82a4f (patch)
tree16858025d8139ac281483431818ad60c463ea1fe /configure.ac
parentd85e89e25bf5c7f531cb35f9abc401b604b9772d (diff)
Bump poppler requirement to 0.8.0.
2008-04-12 Carlos Garcia Campos <carlosgc@gnome.org> * configure.ac: * backend/pdf/ev-poppler.cc: Bump poppler requirement to 0.8.0. svn path=/trunk/; revision=3001
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 1 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 6afc872..2b5bca1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -209,7 +209,7 @@ AC_ARG_ENABLE(pdf,
[AC_HELP_STRING([--enable-pdf], [Compile with pdf support])],enable_pdf="$enableval",enable_pdf=yes)
if test "x$enable_pdf" = "xyes"; then
- POPPLER_REQUIRED=0.6
+ POPPLER_REQUIRED=0.8.0
PKG_CHECK_MODULES(POPPLER, poppler-glib >= $POPPLER_REQUIRED,enable_pdf=yes,enable_pdf=no)
if test "x$enable_pdf" = "xyes"; then
@@ -220,20 +220,8 @@ if test "x$enable_pdf" = "xyes"; then
evince_save_LIBS=$LIBS
LIBS="$LIBS $POPPLER_LIBS"
AC_CHECK_FUNCS(poppler_page_render)
- AC_CHECK_FUNCS(poppler_page_render_for_printing)
- AC_CHECK_FUNCS(poppler_page_get_image)
LIBS=$evince_save_LIBS
- poppler_version=`$PKG_CONFIG --modversion poppler-glib`
- if test x$poppler_version = x0.6; then
- poppler_version=0.6.0
- fi
- POPPLER_MAJOR_VERSION=`echo $poppler_version | sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\).*/\2 /'`
- POPPLER_MINOR_VERSION=`echo $poppler_version | sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\).*/\3 /'`
-
- AC_DEFINE_UNQUOTED([POPPLER_MAJOR_VERSION], $POPPLER_MAJOR_VERSION, [Poppler major version number])
- AC_DEFINE_UNQUOTED([POPPLER_MINOR_VERSION], $POPPLER_MINOR_VERSION, [Poppler minor version number])
-
PKG_CHECK_MODULES(CAIRO_PDF, cairo-pdf, enable_cairo_pdf=yes, enable_cairo_pdf=no)
if test x$enable_cairo_pdf = xyes; then
AC_DEFINE([HAVE_CAIRO_PDF], [1], [defined if cairo-pdf is available])