Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2008-04-08 09:50:20 (GMT)
committer Carlos Garcia Campos <carlosgc@src.gnome.org>2008-04-08 09:50:20 (GMT)
commitf210958704e219d23ceebd8b5ed3603f789a1686 (patch)
treea7a9dda42f0e5d75ddf4adeba4c197c8532875de /configure.ac
parentaf926e18f4cd9393fc32293f1065e8e41b996426 (diff)
Fix build (again) when poppler version is 0.6
2008-04-08 Carlos Garcia Campos <carlosgc@gnome.org> * configure.ac: Fix build (again) when poppler version is 0.6 svn path=/trunk/; revision=2997
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 35bc728..3b25d38 100644
--- a/configure.ac
+++ b/configure.ac
@@ -224,11 +224,12 @@ if test "x$enable_pdf" = "xyes"; then
AC_CHECK_FUNCS(poppler_page_get_image)
LIBS=$evince_save_LIBS
- POPPLER_MAJOR_VERSION=`$PKG_CONFIG --modversion poppler-glib | sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\).*/\2 /'`
- POPPLER_MINOR_VERSION=`$PKG_CONFIG --modversion poppler-glib | sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\).*/\3 /'`
- if test -z "$POPPLER_MINOR_VERSION"; then
- POPPLER_MINOR_VERSION=0
+ poppler_version=`$PKG_CONFIG --modversion poppler-glib`
+ if test x$poppler_version = x0.6; then
+ poppler_version=0.6.0
fi
+ POPPLER_MAJOR_VERSION=`echo $poppler_version | sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\).*/\2 /'`
+ POPPLER_MINOR_VERSION=`echo $poppler_version | sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\).*/\3 /'`
AC_DEFINE_UNQUOTED([POPPLER_MAJOR_VERSION], $POPPLER_MAJOR_VERSION, [Poppler major version number])
AC_DEFINE_UNQUOTED([POPPLER_MINOR_VERSION], $POPPLER_MINOR_VERSION, [Poppler minor version number])