Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNickolay V. Shmyrev <nshmyrev@src.gnome.org>2005-10-17 17:37:10 (GMT)
committer Nickolay V. Shmyrev <nshmyrev@src.gnome.org>2005-10-17 17:37:10 (GMT)
commit0c56e0840f68b6594dd54040a99440d94286a5e6 (patch)
tree3c489c8cd390b077eafbcc85511a37634c737959 /configure.ac
parent68c3ea96e506ace9a8c3cb2e4b6f1a8e1e216890 (diff)
Don't link with ltiff if tiff is disabled.
* configure.ac: Don't link with ltiff if tiff is disabled.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b280ed3..3fd1e9b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -81,12 +81,12 @@ if test "x$enable_dbus" = "xyes" ; then
fi
SHELL_CFLAGS="$SHELL_CORE_CFLAGS $DBUS_CFLAGS"
-SHELL_LIBS="$SHELL_CORE_LIBS $DBUS_LIBS -ltiff -lz"
+SHELL_LIBS="$SHELL_CORE_LIBS $DBUS_LIBS -lz"
AC_SUBST(SHELL_CFLAGS)
AC_SUBST(SHELL_LIBS)
FRONTEND_CFLAGS="$FRONTEND_CORE_CFLAGS"
-FRONTEND_LIBS="$FRONTEND_CORE_LIBS -ltiff -lz"
+FRONTEND_LIBS="$FRONTEND_CORE_LIBS -lz"
AC_SUBST(FRONTEND_CFLAGS)
AC_SUBST(FRONTEND_LIBS)
@@ -176,6 +176,8 @@ if test "x$enable_tiff" = "xyes"; then
fi
if test "x$enable_tiff" = "xyes"; then
AC_DEFINE([ENABLE_TIFF], [1], [Enable multipage tiff support.])
+ FRONTEND_LIBS="$FRONTEND_LIBS -ltiff"
+ SHELL_LIBS="$SHELL_LIBS -ltiff"
else
AC_MSG_WARN("Tiff support is disabled since tiff library version 3.6 or newer not found")
fi