Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <mpg@redhat.com>2005-07-11 17:38:35 (GMT)
committer Marco Pesenti Gritti <marco@src.gnome.org>2005-07-11 17:38:35 (GMT)
commit13c49bea656a4f495e2c4baedab130eab367ae4f (patch)
treea987238e2e9b0bed2f6312df490d96c2641fb6c9 /configure.ac
parent0202a575af908e78d0fd9c2a1730989f499d2fb3 (diff)
Allow to enable/disable the pixbuf backend. Default to off for now. If we
2005-07-11 Marco Pesenti Gritti <mpg@redhat.com> * Makefile.am: * backend/Makefile.am: * backend/ev-document-factory.c: (ev_document_type_get_from_mime): * configure.ac: * shell/ev-document-types.c: (ev_document_types_add_filters): Allow to enable/disable the pixbuf backend. Default to off for now. If we want it enabled we should really put mime types in the desktop, implement properties etc. * properties/evince-properties.c: Initialize error to NULL. Check error is not NULL before freeing.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ddb7b23..50cbfc6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -248,6 +248,17 @@ AM_CONDITIONAL(WITH_TYPE1_FONTS, test x$enable_type1_fonts = xyes)
dnl ================== End of dvi checks ===================================================
+dnl ================== pixbuf checks ===================================================
+
+AC_ARG_ENABLE(pixbuf,
+ [AC_HELP_STRING([--enable-pixbuf], [Compile with support of pixbuf])],enable_pixbuf="$enableval",enable_pixbuf=no)
+if test "x$enable_pixbuf" = "xyes"; then
+ AC_DEFINE([ENABLE_PIXBUF], [1], [Enable pixbuf support.])
+fi
+AM_CONDITIONAL(ENABLE_PIXBUF, test x$enable_pixbuf = xyes)
+
+dnl ================== End of dvi checks ===================================================
+
dnl =================== Mime types list ====================================================
EVINCE_MIME_TYPES="application/pdf;application/postscript;application/x-gzpostscript"