Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Garcia <danigm@yaco.es>2010-06-26 14:12:57 (GMT)
committer Carlos Garcia Campos <carlosgc@gnome.org>2010-06-26 14:24:32 (GMT)
commit18d2af9bce80392407fae997c8dfa029f5a54123 (patch)
treecc2f2d7d7c000ea6985cf52fe6ea41fc6bc709ee /configure.ac
parent05fdc61391b2d3f13a539ba8c870a4b60342d06a (diff)
[pdf] Implement EvDocumentText interface
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d193cee..f9afa56 100644
--- a/configure.ac
+++ b/configure.ac
@@ -477,6 +477,10 @@ if test "x$enable_pdf" = "xyes"; then
PKG_CHECK_MODULES(POPPLER, poppler-glib >= $POPPLER_REQUIRED libxml-2.0 >= $LIBXML_REQUIRED,enable_pdf=yes,enable_pdf=no)
if test "x$enable_pdf" = "xyes"; then
+ evince_save_LIBS=$LIBS
+ LIBS="$LIBS $POPPLER_LIBS"
+ AC_CHECK_FUNCS(poppler_page_get_text_layout)
+ LIBS=$evince_save_LIBS
PKG_CHECK_MODULES(CAIRO_PDF, cairo-pdf, enable_cairo_pdf=yes, enable_cairo_pdf=no)
if test x$enable_cairo_pdf = xyes; then
AC_DEFINE([HAVE_CAIRO_PDF], [1], [defined if cairo-pdf is available])