Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2009-09-21 18:35:21 (GMT)
committer Carlos Garcia Campos <carlosgc@gnome.org>2009-09-22 08:10:31 (GMT)
commit2a5ce34fce3f7ab37587b644a3f4a961204cd504 (patch)
treeda4ed25c4fb4ce639683fa8afc81212aa43c6830 /configure.ac
parentb790da7f9d8ced041675df7458bc78eea0f3ddbd (diff)
[build] Add --disable-tests to disable tests during distcheck
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fe198a6..6208b0c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -308,6 +308,12 @@ if test "x$enable_debug" = "xyes"; then
DEBUG_FLAGS="-DEV_ENABLE_DEBUG"
fi
+AC_ARG_ENABLE([tests],
+ AC_HELP_STRING([--enable-tests], [Disable tests]),
+ enable_tests="$enableval",
+ enable_tests=yes)
+
+AM_CONDITIONAL(ENABLE_TESTS, test x$enable_tests = xyes)
LIBDOCUMENT_CFLAGS="$LIBDOCUMENT_CFLAGS $DEBUG_FLAGS"
LIBDOCUMENT_LIBS="$LIBDOCUMENT_LIBS"
@@ -746,6 +752,7 @@ Configure summary:
Gtk-Doc Support....: $enable_gtk_doc
Debug mode.........: $enable_debug
GObj. Introspection: $enable_introspection
+ Tests..............: $enable_tests
PDF Backend........: $enable_pdf
PostScript Backend.: $enable_ps