Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorYevgen Muntyan <muntyan@tamu.edu>2006-11-30 20:58:58 (GMT)
committer Nickolay V. Shmyrev <nshmyrev@src.gnome.org>2006-11-30 20:58:58 (GMT)
commit2dc20d298ea8064cf09bc5acc201a9df4e4cd4f0 (patch)
tree9308fb0aca3465335c0399cbdf4c1f45bd39e19b /configure.ac
parentb62cd9e5c51ac21bde4a328c52f463913d84a1dc (diff)
Make pdf compilation optional. See bug #38007.
2006-11-30 Yevgen Muntyan <muntyan@tamu.edu> * Makefile.am: * backend/Makefile.am: * backend/ev-document-factory.c: (ev_document_factory_add_filters): * configure.ac: * shell/ev-window.c: (build_comments_string): Make pdf compilation optional. See bug #38007.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ed19edc..a299f09 100644
--- a/configure.ac
+++ b/configure.ac
@@ -198,6 +198,7 @@ if test "x$enable_pdf" = "xyes"; then
AC_DEFINE([ENABLE_PDF], [1], [Enable pdf support.])
FRONTEND_LIBS="$FRONTEND_LIBS $POPPLER_LIBS"
SHELL_LIBS="$SHELL_LIBS $POPPLER_LIBS"
+ SHELL_CFLAGS="$SHELL_CFLAGS $POPPLER_CFLAGS"
else
AC_MSG_WARN("PDF support is disabled since poppler-glib library version $POPPLER_REQUIRED or newer not found")
fi