Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2008-01-13 11:23:44 (GMT)
committer Carlos Garcia Campos <carlosgc@src.gnome.org>2008-01-13 11:23:44 (GMT)
commit4207c30cf856a79bc6e23219bf43554470cd4b0b (patch)
tree3a3e7adee75aea1745aae016a53c4dec333c749b /configure.ac
parent9fa361629b670a428f9106128f5a66676db9a9a7 (diff)
Bump requirements to libspectre 0.2.0. Fixes bug #507705.
2008-01-13 Carlos Garcia Campos <carlosgc@gnome.org> * configure.ac: * backend/dvi/cairo-device.c: (dvi_cairo_draw_ps): * backend/ps/ev-spectre.c: (ps_document_render): Bump requirements to libspectre 0.2.0. Fixes bug #507705. svn path=/trunk/; revision=2816
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 7c50c96..afd29ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -261,9 +261,10 @@ fi
AM_CONDITIONAL(ENABLE_PDF, test x$enable_pdf = xyes)
dnl ================== end of pdf checks ============================================
+SPECTRE_REQUIRED=0.2.0
dnl libspectre (used by ps and dvi backends)
-PKG_CHECK_MODULES(SPECTRE, libspectre,have_spectre=yes,have_spectre=no)
+PKG_CHECK_MODULES(SPECTRE, libspectre >= $SPECTRE_REQUIRED,have_spectre=yes,have_spectre=no)
AM_CONDITIONAL(HAVE_SPECTRE, test x$have_spectre = xyes)
if test "x$have_spectre" = "xyes"; then
AC_DEFINE([HAVE_SPECTRE], [1], [Have libpectre])
@@ -285,7 +286,7 @@ if test x$enable_ps = xyes; then
GS_VERSION=`gs --version | head -n 1 | sed 's/\([[0-9]]*\)\.\([[0-9]]*\).*/\1/'`
AC_MSG_RESULT(found $GS_VERSION)
if test "$GS_VERSION" -lt "7"; then
- AC_MSG_WARN([PS support is disabled since libspectre or Ghostscript (version >= 7) are needed])
+ AC_MSG_WARN([PS support is disabled since libspectre (version >= $SPECTRE_REQUIRED) or Ghostscript (version >= 7) are needed])
enable_ps=no
else
AC_ARG_WITH(gs-aa-params,