Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEduardo Lima <eduardo.lima@indt.org.br>2005-12-21 21:29:39 (GMT)
committer Eduardo de Barros Lima <eblima@src.gnome.org>2005-12-21 21:29:39 (GMT)
commit469d80f6b3dcfc2900f0faf5ab553fb3531c41f9 (patch)
tree82eb06b5273b9371f2a93423a761742e78cb96c2 /configure.ac
parentad8c5759a29adf76e69b525c6e5e69a6999d3382 (diff)
Included option in configure to make ps backend compilation optional with
2005-12-21 Eduardo Lima <eduardo.lima@indt.org.br> * Makefile.am: * configure.ac: * backend/Makefile.am: * backend/ev-document-factory.c: * shell/ev-document-types.c: Included option in configure to make ps backend compilation optional with --disable-ps.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3fe05b0..b66c188 100644
--- a/configure.ac
+++ b/configure.ac
@@ -137,6 +137,15 @@ dnl for backtrace()
AC_CHECK_HEADERS([execinfo.h])
dnl ================== ggv checks ===================================================
+AC_ARG_ENABLE(ps,
+ [AC_HELP_STRING([--disable-ps], [Compile without PostScript backend])],enable_ps=$enableval,enable_ps="yes")
+
+if test x$enable_ps = xyes; then
+ AC_DEFINE([ENABLE_PS], [1], [Enable support for PostScript files.])
+fi
+
+AM_CONDITIONAL(ENABLE_PS, test x$enable_ps = xyes)
+if test x$enable_ps = xyes; then
AC_ARG_WITH(gs-pkg,
[ --with-gs=dir Directory Where GhostScript package is installed.])
@@ -162,6 +171,7 @@ fi
AA_PARMS="-sDEVICE=x11alpha -dNOPLATFONTS"
AC_DEFINE_UNQUOTED(ALPHA_PARAMS, "$AA_PARMS", [Anti-aliasing parameters for Ghostscript.])
AC_MSG_RESULT(Antialiasing parameters for Ghostscript: $AA_PARMS)
+fi
dnl ======================== End of ggv checks =================================
dnl ================== tiff checks ===================================================
@@ -279,8 +289,11 @@ dnl ================== End of comic book checks ================================
dnl =================== Mime types list ====================================================
-EVINCE_MIME_TYPES="application/pdf;application/postscript;application/x-gzpostscript"
+EVINCE_MIME_TYPES="application/pdf"
+if test "x$disable_ps" = "xno" ; then
+ EVINCE_MIME_TYPES="$EVINCE_MIME_TYPES;application/postscript;application/x-gzpostscript"
+fi
if test "x$enable_dvi" = "xyes"; then
EVINCE_MIME_TYPES="$EVINCE_MIME_TYPES;application/x-dvi"
fi