Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Kretzschmar <martink@src.gnome.org>2005-07-05 21:25:06 (GMT)
committer Martin Kretzschmar <martink@src.gnome.org>2005-07-05 21:25:06 (GMT)
commit5c7621f5c00e82a787d3cdbc038cf833e581cfa7 (patch)
tree4045a04889f247764c96eea7b58528630b8c0bb9 /configure.ac
parent95f22fc9a3ddca87ed14bd8e6e39e2e78f67caeb (diff)
check if dbus-binding-tool is installed. Not the case on current
Ubuntu breezy, it seems.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a6ee3d7..d28f9e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -56,6 +56,12 @@ PKG_CHECK_EXISTS([dbus-glib-1 >= $DBUS_GLIB_REQUIRED], [enable_dbus=yes],
if test "x$enable_dbus" = "xyes" ; then
PKG_CHECK_MODULES([DBUS], [dbus-glib-1 >= $DBUS_GLIB_REQUIRED])
+ AC_PATH_PROG([DBUS_BINDING_TOOL], [dbus-binding-tool], [no])
+
+ if test x$DBUS_BINDING_TOOL = "xno" ; then
+ AC_MSG_ERROR([dbus-binding-tool executable not found in your path - should be installed with dbus glib bindings])
+ fi
+
AC_DEFINE([ENABLE_DBUS],[1],[Define if DBUS support is enabled])
AC_DEFINE([ENABLE_METADATA],[1],[Define if metadata support is enabled])