Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <mpg@redhat.com>2005-06-30 08:16:45 (GMT)
committer Marco Pesenti Gritti <marco@src.gnome.org>2005-06-30 08:16:45 (GMT)
commit616f5c97013f1344caa6e899de6cc99664faa5e9 (patch)
treead6392193de5ac668d0b73d8c54afe4c46edf44d /configure.ac
parent574925f7b2618bb12dd6e8d63fcbc08b97c42126 (diff)
Add an optional dbus interface (--enable-dbus). Rework application code,
2005-06-24 Marco Pesenti Gritti <mpg@redhat.com> * shell/ev-application-service.xml: * configure.ac: * shell/Makefile.am: * shell/ev-application.c: * shell/ev-application.h: * shell/ev-window.c: * shell/ev-window.h: * shell/main.c: Add an optional dbus interface (--enable-dbus). Rework application code, mainly to be easier to use "remotely". Do not open multiple windows with the same document, spatial evince!
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7e7ab04..823e5ce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,6 +33,7 @@ AC_SUBST(GETTEXT_PACKAGE)
AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE", [Gettext package.])
POPPLER_REQUIRED=0.3.3
+DBUS_GLIB_REQUIRED=0.33
PKG_CHECK_MODULES(LIBEVPRIVATE, gtk+-2.0 >= 2.4.0)
PKG_CHECK_MODULES(TOOLBAR_EDITOR, gtk+-2.0 >= 2.4.0 libgnomeui-2.0 >= 2.4.0)
@@ -48,6 +49,20 @@ PKG_CHECK_MODULES(POPPLER_GLIB, poppler-glib >= $POPPLER_REQUIRED)
GLIB_GENMARSHAL=`$PKG_CONFIG --variable=glib_genmarshal glib-2.0`
AC_SUBST(GLIB_GENMARSHAL)
+AC_ARG_ENABLE([dbus],
+ AS_HELP_STRING([--enable-dbus],[Enable DBUS (default=no)]),
+ [enable_dbus=$enableval],
+ [enable_dbus=no])
+
+AC_MSG_RESULT([$enable_dbus])
+
+if test "x$enable_dbus" = "xyes" ; then
+ AC_DEFINE([ENABLE_DBUS],[1],[Define if DBUS support is enabled])
+ PKG_CHECK_MODULES([DBUS], [dbus-glib-1 >= $DBUS_GLIB_REQUIRED])
+fi
+
+AM_CONDITIONAL([ENABLE_DBUS], [test "x$enable_dbus" = "xyes"])
+
dnl Compile with disable-deprecated switches
AC_ARG_ENABLE(deprecated,