Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2009-10-19 17:27:45 (GMT)
committer Carlos Garcia Campos <carlosgc@gnome.org>2009-10-20 16:26:49 (GMT)
commit66e5636dcaace0d9a98845490b09721c12ce3d2b (patch)
treef59d5c02d4f30658b17f317944e2c86f77f8afdc /configure.ac
parent3f28adc16f40da7048d9693278ed2940aa1e39f0 (diff)
Run evince instances in different processes instead of single instance
- When built with DBus support a daemon is used to keep track of opened documents and reload them when reopened. - Crash recovery code has been removed. - Metadata migration code has been moved from main.c to ev-daemon.c, so that it's only run once on daemon startup. Fixes bgo#583680, bgo#434966, bgo#497388, bgo#524633 and bgo#586087.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6208b0c..096366d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -269,6 +269,10 @@ AC_SUBST([DBUS_LIBS])
AM_CONDITIONAL([ENABLE_DBUS], [test "$enable_dbus" = "yes"])
+if test "$enable_dbus" = "yes"; then
+ PKG_CHECK_MODULES([EV_DAEMON], [gthread-2.0 gio-2.0 >= $GLIB_REQUIRED dbus-glib-1 >= $DBUS_GLIB_REQUIRED])
+fi
+
dnl ========= Check for GConf
AC_MSG_CHECKING([whether GConf support is requested])
@@ -339,6 +343,10 @@ FRONTEND_LIBS="$FRONTEND_CORE_LIBS -lz"
AC_SUBST(FRONTEND_CFLAGS)
AC_SUBST(FRONTEND_LIBS)
+EV_DAEMON_CFLAGS="$EV_DAEMON_CFLAGS $DEBUG_FLAGS"
+AC_SUBST([EV_DAEMON_CFLAGS])
+AC_SUBST([EV_DAEMON_LIBS])
+
# Check for Nautilus property page build
AC_ARG_ENABLE([nautilus],
[AS_HELP_STRING([--disable-nautilus],[Build the nautilus extensions])],