Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2009-02-05 09:44:50 (GMT)
committer Carlos Garcia Campos <carlosgc@src.gnome.org>2009-02-05 09:44:50 (GMT)
commit841369ba5c77e58a6fa19723b33d04720a7d4fec (patch)
tree1c50e5522fdb8994fe3a203c3fe29d5c6843bc2b /configure.ac
parentee88daeea5519ca669244684877effbcea42fb56 (diff)
Make session manager code compile for w32. These changes have been taken
2009-02-05 Carlos Garcia Campos <carlosgc@gnome.org> * configure.ac: * cut-n-paste/smclient/Makefile.am: * cut-n-paste/smclient/eggdesktopfile.c: * cut-n-paste/smclient/eggsmclient-win32.c: * shell/main.c: Make session manager code compile for w32. These changes have been taken from upstream libegg. Based on patch by Hib Eris. See bug #339172. svn path=/trunk/; revision=3416
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c04a07b..e66b125 100644
--- a/configure.ac
+++ b/configure.ac
@@ -72,6 +72,20 @@ AC_SUBST(GETTEXT_PACKAGE)
AC_DEFINE_UNQUOTED([GETTEXT_PACKAGE],["$GETTEXT_PACKAGE"],[Gettext package])
AM_GLIB_GNU_GETTEXT
+dnl check for win32 platform
+AC_MSG_CHECKING([for Win32 platform])
+case "$host" in
+ *-*-mingw*|*-*-cygwin*)
+ platform_win32=yes
+ AC_CHECK_TOOL(WINDRES, windres)
+ ;;
+ *)
+ platform_win32=no
+ ;;
+esac
+AC_MSG_RESULT([$platform_win32])
+AM_CONDITIONAL(PLATFORM_WIN32, test "$platform_win32" = "yes")
+
dnl Check dependencies
# LIB_CFLAGS for helpers and generic widgets. (libdocument, cut-and-paste)