Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNickolay V. Shmyrev <nshmyrev@src.gnome.org>2006-04-29 10:38:22 (GMT)
committer Nickolay V. Shmyrev <nshmyrev@src.gnome.org>2006-04-29 10:38:22 (GMT)
commitb20dd164ff2a12342bcfbaffbe3fec41e05fa001 (patch)
tree4340d42009fac1ba8c56cde071d5ddcd52fbcdb8 /configure.ac
parent3548d5d1fd0770846c7966269fdcfd28d3947da1 (diff)
Update to djvulibre-3.5.17, now it uses pkg-config. Fix for the bug
* configure.ac: * djvu/Makefile.am: * djvu/djvu-text.h: Update to djvulibre-3.5.17, now it uses pkg-config. Fix for the bug 339868.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 4 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index b3a1a8b..04bc517 100644
--- a/configure.ac
+++ b/configure.ac
@@ -218,20 +218,17 @@ AC_ARG_ENABLE(djvu,
[AC_HELP_STRING([--enable-djvu], [Compile with support of djvu viewer])],enable_djvu="$enableval",enable_djvu=no)
if test "x$enable_djvu" = "xyes"; then
- AC_CHECK_HEADERS([libdjvu/ddjvuapi.h],enable_djvu=yes,enable_djvu=no,)
- if test "x$enable_djvu" = "xyes"; then
- AC_CHECK_LIB([djvulibre],ddjvu_context_create,enable_djvu=yes,enable_djvu=no,"-lpthread")
- AC_CHECK_LIB([djvulibre],ddjvu_document_get_pageinfo,enable_djvu=yes,enable_djvu=no,"-lpthread")
- AC_CHECK_LIB([djvulibre],ddjvu_document_get_pagetext,enable_djvu=yes,enable_djvu=no,"-lpthread")
- fi
+DJVULIBRE_REQUIRED=3.5.17
+
+PKG_CHECK_MODULES(DJVU, ddjvuapi >= 3.5.17, enable_djvu=yes, enable_djvu=no)
if test "x$enable_djvu" = "xyes"; then
AC_DEFINE([ENABLE_DJVU], [1], [Enable djvu viewer support.])
else
AC_MSG_WARN([
** Djvu support is disabled since a recent version of the djvulibre
-** library was not found. You need at least djvulibre-3.5.16 which
+** library was not found. You need at least djvulibre-3.5.17 which
** can be found on http://djvulibre.djvuzone.org
])
fi