Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2010-05-03 12:37:30 (GMT)
committer Carlos Garcia Campos <carlosgc@gnome.org>2010-05-03 12:38:45 (GMT)
commitb329a61d561198cd405721372580d05476c2240a (patch)
treec4751ad802d437999a4b3f7b3d1e811bbe8b3f95 /configure.ac
parent8c280e4b0018f36ba525a909aae8aee889e4617d (diff)
[shell] Port override_restrictions gconf key to GSettings
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8f18357..3621326 100644
--- a/configure.ac
+++ b/configure.ac
@@ -85,6 +85,8 @@ m4_pattern_allow([AM_V_GEN])dnl Make autoconf not complain about the rule below
EV_INTLTOOL_EVINCE_BACKEND_RULE='%.evince-backend: %.evince-backend.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*.po) ; $(AM_V_GEN) LC_ALL=C $(INTLTOOL_MERGE) -d -u -c $(top_builddir)/po/.intltool-merge-cache $(top_srcdir)/po $< [$]@'
AC_SUBST([EV_INTLTOOL_EVINCE_BACKEND_RULE])
+GLIB_GSETTINGS
+
# Check which platform to use
AC_MSG_CHECKING([for which platform to build])
@@ -122,8 +124,9 @@ AM_CONDITIONAL([PLATFORM_WIN32],[test "$with_platform" = "win32"])
dnl Specify required versions of dependencies
DBUS_GLIB_REQUIRED=0.70
GTK_REQUIRED=2.20.0
-GLIB_REQUIRED=2.18.0
+GLIB_REQUIRED=2.25.3
KEYRING_REQUIRED=2.22.0
+GCONF_REQUIRED=2.31.2
AC_SUBST([GLIB_REQUIRED])
AC_SUBST([GTK_REQUIRED])
@@ -312,7 +315,7 @@ AC_MSG_RESULT([$with_gconf])
AM_CONDITIONAL([WITH_GCONF],[test "$with_gconf" = "yes"])
if test "$with_gconf" = "yes"; then
- PKG_CHECK_MODULES([GCONF],[gconf-2.0])
+ PKG_CHECK_MODULES([GCONF],[gconf-2.0 >= $GCONF_REQUIRED])
AC_DEFINE([WITH_GCONF],[1],[Define if GConf support is enabled])
AM_GCONF_SOURCE_2