Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHib Eris <hib@hiberis.nl>2010-04-15 12:11:34 (GMT)
committer Hib Eris <hib@hiberis.nl>2010-04-15 12:51:57 (GMT)
commitbd26e60016e9e08c1784ee2d90695cc7eeb7daee (patch)
tree9783bda56c2f0496f061fb197a5b24f253197fbf /configure.ac
parentb3f64eef14e1a0be9896d2c7d1bdc6416aa2fa3a (diff)
Make gnome-doc-utils optional
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 29 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 01eef2b..8f18357 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,7 +66,6 @@ AC_PROG_SED
AC_PATH_PROG([GLIB_GENMARSHAL], [glib-genmarshal])
AC_PATH_PROG([GLIB_MKENUMS],[glib-mkenums])
-GNOME_DOC_INIT
GNOME_MAINTAINER_MODE_DEFINES
GNOME_COMPILE_WARNINGS
GNOME_CXX_WARNINGS
@@ -715,6 +714,34 @@ AC_SUBST(EVINCE_MIME_TYPES)
AC_CHECK_FUNC(localtime_r, AC_DEFINE(HAVE_LOCALTIME_R, 1, [Defines if localtime_r is available on your system]))
# *****************
+# Help files
+# *****************
+
+GNOME_DOC_INIT([], gnome_doc_utils=yes, gnome_doc_utils=no)
+
+AC_ARG_ENABLE(help,
+ [AS_HELP_STRING([--disable-help], [Disable offline help files])],
+ [enable_help=$enableval],
+ [enable_help=yes])
+
+if test "x$enable_help" = "xyes" && test "x$os_win32" = "xyes" ; then
+ AC_MSG_WARN([Offline help is disabled (not implemented on Windows).])
+ enable_help=no
+fi
+
+if test "x$enable_help" = "xyes" && test "x$gnome_doc_utils" == "xno"; then
+ AC_MSG_ERROR(
+ [gnome-doc-utils not found; use --disable-help to disable help files]
+ )
+fi
+
+if test "x$enable_help" = "xyes"; then
+ AC_DEFINE([OFFLINE_HELP_ENABLED], [1], [Enable offline help])
+fi
+
+AM_CONDITIONAL(ENABLE_HELP, test "x$enable_help" = "xyes")
+
+# *****************
# API documentation
# *****************
@@ -825,6 +852,7 @@ Configure summary:
Keyring Support....: $with_keyring
DBUS Support.......: $enable_dbus
SM client support..: $with_smclient
+ Help files.........: $enable_help
Nautilus Plugin....: $enable_nautilus
Thumbnailer........: $enable_thumbnailer
Previewer..........: $enable_previewer