Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2010-05-22 08:34:12 (GMT)
committer Carlos Garcia Campos <carlosgc@gnome.org>2010-05-22 08:38:05 (GMT)
commitc71cb3c049f191734d90cd144cd5ec8920c02abe (patch)
tree152d9ef2368814d0cd9a8f1f7862d95eaac18cfd /configure.ac
parent985f7016929bae86f89e63fc2b7b56145fbd0382 (diff)
[shell] Do not use the gconf gsettings backend any more
- rename keys to follow gsettings name restrictions (s/_/-/) - remove the hardcoding of the gconf backend - use new gsettings macros as they have changed in glib 2.25.6 Based on patch by Matthias Clasen, see bug #619335.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 14a2a7c..ece94a3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -124,9 +124,8 @@ AM_CONDITIONAL([PLATFORM_WIN32],[test "$with_platform" = "win32"])
dnl Specify required versions of dependencies
DBUS_GLIB_REQUIRED=0.70
GTK_REQUIRED=2.21.0
-GLIB_REQUIRED=2.25.3
+GLIB_REQUIRED=2.25.6
KEYRING_REQUIRED=2.22.0
-GCONF_REQUIRED=2.31.2
AC_SUBST([GLIB_REQUIRED])
AC_SUBST([GTK_REQUIRED])
@@ -314,7 +313,7 @@ AC_MSG_RESULT([$with_gconf])
AM_CONDITIONAL([WITH_GCONF],[test "$with_gconf" = "yes"])
if test "$with_gconf" = "yes"; then
- PKG_CHECK_MODULES([GCONF],[gconf-2.0 >= $GCONF_REQUIRED])
+ PKG_CHECK_MODULES([GCONF],[gconf-2.0])
AC_DEFINE([WITH_GCONF],[1],[Define if GConf support is enabled])
AM_GCONF_SOURCE_2