Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2008-04-07 20:49:53 (GMT)
committer Carlos Garcia Campos <carlosgc@src.gnome.org>2008-04-07 20:49:53 (GMT)
commitd069b08079f06c8c062b9994ad97762d59829370 (patch)
tree54a9068ee7d895859761f390394cb9ba8174582a /configure.ac
parent10288dd7e3cb4d0742a32b6327baded62dd0ebfc (diff)
Fix build in FreeBSD. Based on patch by Michael Johnson. Fixes bug
2008-04-07 Carlos Garcia Campos <carlosgc@gnome.org> * configure.ac: Fix build in FreeBSD. Based on patch by Michael Johnson. Fixes bug #526799. svn path=/trunk/; revision=2995
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 08db7f0..35bc728 100644
--- a/configure.ac
+++ b/configure.ac
@@ -224,8 +224,8 @@ if test "x$enable_pdf" = "xyes"; then
AC_CHECK_FUNCS(poppler_page_get_image)
LIBS=$evince_save_LIBS
- POPPLER_MAJOR_VERSION=`$PKG_CONFIG --modversion poppler-glib | sed 's/0\.\([[0-9]]*\)\(\.\([[0-9]]*\)\)\?/\1/'`
- POPPLER_MINOR_VERSION=`$PKG_CONFIG --modversion poppler-glib | sed 's/0\.\([[0-9]]*\)\(\.\([[0-9]]*\)\)\?/\3/'`
+ POPPLER_MAJOR_VERSION=`$PKG_CONFIG --modversion poppler-glib | sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\).*/\2 /'`
+ POPPLER_MINOR_VERSION=`$PKG_CONFIG --modversion poppler-glib | sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\).*/\3 /'`
if test -z "$POPPLER_MINOR_VERSION"; then
POPPLER_MINOR_VERSION=0
fi
@@ -234,12 +234,12 @@ if test "x$enable_pdf" = "xyes"; then
AC_DEFINE_UNQUOTED([POPPLER_MINOR_VERSION], $POPPLER_MINOR_VERSION, [Poppler minor version number])
PKG_CHECK_MODULES(CAIRO_PDF, cairo-pdf, enable_cairo_pdf=yes, enable_cairo_pdf=no)
- if test x$enable_cairo_pdf == xyes; then
+ if test x$enable_cairo_pdf = xyes; then
AC_DEFINE([HAVE_CAIRO_PDF], [1], [defined if cairo-pdf is available])
fi
PKG_CHECK_MODULES(CAIRO_PS, cairo-ps, enable_cairo_ps=yes, enable_cairo_ps=no)
- if test x$enable_cairo_ps == xyes; then
+ if test x$enable_cairo_ps = xyes; then
AC_DEFINE([HAVE_CAIRO_PS], [1], [defined if cairo-ps is available])
fi
else