Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2005-07-05 17:31:30 (GMT)
committer Christian Persch <chpe@src.gnome.org>2005-07-05 17:31:30 (GMT)
commite688147c85543bb01a7c28a4c18548762ab9d98e (patch)
tree724242d63a5d765763ac58d9e09221e944d9fac6 /configure.ac
parent8d858ef399ef70a2c9efb391242e8c8be70e2109 (diff)
Use AM_CONDITIONAL unconditionally, fixes the build with DBUS disabled.
2005-07-05 Christian Persch <chpe@cvs.gnome.org> * configure.ac: Use AM_CONDITIONAL unconditionally, fixes the build with DBUS disabled.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 70084aa..ac18288 100644
--- a/configure.ac
+++ b/configure.ac
@@ -57,6 +57,7 @@ AC_ARG_ENABLE([dbus],
AC_MSG_RESULT([$enable_dbus])
+DBUS_VERSION=
if test "x$enable_dbus" = "xyes" ; then
AC_DEFINE([ENABLE_DBUS],[1],[Define if DBUS support is enabled])
AC_DEFINE([ENABLE_METADATA],[1],[Define if metadata support is enabled])
@@ -64,11 +65,11 @@ if test "x$enable_dbus" = "xyes" ; then
DBUS_VERSION=`$PKG_CONFIG --modversion dbus-glib-1 | sed 's/0.\([[0-9]]*\)/\1/'`
AC_DEFINE_UNQUOTED(DBUS_VERSION, $DBUS_VERSION, [DBUS version.])
- AM_CONDITIONAL([DBUS_TOOL_NO_PREFIX], [test "x$DBUS_VERSION" = "x33"])
fi
AM_CONDITIONAL([ENABLE_DBUS], [test "x$enable_dbus" = "xyes"])
AM_CONDITIONAL([ENABLE_METADATA], [test "x$enable_dbus" = "xyes"])
+AM_CONDITIONAL([DBUS_TOOL_NO_PREFIX], [test "x$DBUS_VERSION" = "x33"])
dnl Check for Nautilus property page build
AC_ARG_ENABLE(nautilus,