Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2008-03-22 15:36:31 (GMT)
committer Carlos Garcia Campos <carlosgc@src.gnome.org>2008-03-22 15:36:31 (GMT)
commitefc1202860ecf9849d517e3ca42787074b5c4d08 (patch)
tree3111570150c2db2a9cf34bc8b655433e2dcb9b80 /configure.ac
parent8dd1b52c6b151c1c805714d67fb9aa8aa4185619 (diff)
Add a configure option to enable/diable DBus. Patch by Rémi Cardona.
2008-03-22 Carlos Garcia Campos <carlosgc@gnome.org> * configure.ac: Add a configure option to enable/diable DBus. Patch by Rémi Cardona. Fixes bug 521797. svn path=/trunk/; revision=2976
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 18 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 4b0ddda..73c8196 100644
--- a/configure.ac
+++ b/configure.ac
@@ -104,25 +104,31 @@ GLIB_GENMARSHAL=`$PKG_CONFIG --variable=glib_genmarshal glib-2.0`
AC_SUBST(GLIB_GENMARSHAL)
dnl ========= Check for DBUS
-PKG_CHECK_MODULES([DBUS], [dbus-glib-1 >= $DBUS_GLIB_REQUIRED],
+AC_ARG_ENABLE(dbus,
+ [AC_HELP_STRING([--enable-dbus], [Compile with support for dbus])],
+ enable_dbus="$enableval",enable_dbus=yes)
+if test "x$enable_dbus" != "xno"; then
+ PKG_CHECK_MODULES([DBUS], [dbus-glib-1 >= $DBUS_GLIB_REQUIRED],
[enable_dbus=yes],[enable_dbus=no])
-AC_SUBST([DBUS_CFLAGS])
-AC_SUBST([DBUS_LIBS])
-if test "x$enable_dbus" = "xno"; then
- AC_MSG_WARN([DBUS support is disabled since dbus $DBUS_GLIB_REQUIRED or higher was not found])
-fi
+ if test "x$enable_dbus" = "xno"; then
+ AC_MSG_WARN([DBUS support is disabled since dbus $DBUS_GLIB_REQUIRED or higher was not found])
+ fi
-if test "x$enable_dbus" = "xyes" ; then
- AC_PATH_PROG([DBUS_BINDING_TOOL], [dbus-binding-tool], [no])
+ if test "x$enable_dbus" = "xyes" ; then
+ AC_PATH_PROG([DBUS_BINDING_TOOL], [dbus-binding-tool], [no])
- if test x$DBUS_BINDING_TOOL = "xno" ; then
- AC_MSG_ERROR([dbus-binding-tool executable not found in your path - should be installed with dbus glib bindings])
- fi
+ if test x$DBUS_BINDING_TOOL = "xno" ; then
+ AC_MSG_ERROR([dbus-binding-tool executable not found in your path - should be installed with dbus glib bindings])
+ fi
- AC_DEFINE([ENABLE_DBUS],[1],[Define if DBUS support is enabled])
+ AC_DEFINE([ENABLE_DBUS],[1],[Define if DBUS support is enabled])
+ fi
fi
+AC_SUBST([DBUS_CFLAGS])
+AC_SUBST([DBUS_LIBS])
+
LIB_CFLAGS="$LIB_CFLAGS $GNOME_CFLAGS"
LIB_LIBS="$LIB_LIBS $GNOME_LIBS"
AC_SUBST(LIB_CFLAGS)