Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2006-12-18 17:01:34 (GMT)
committer Carlos Garcia Campos <carlosgc@src.gnome.org>2006-12-18 17:01:34 (GMT)
commitf09959b414ef0f5112f7c6277a23606e432e2389 (patch)
treeb05e4889fb9d402ff175a6ce5a82c32735709ea2 /configure.ac
parent1a07ffc563175aaa64af6c8e872c24b1ac3e8ea7 (diff)
Make cairo-pdf depedency optional.
2006-12-18 Carlos Garcia Campos <carlosgc@gnome.org> * configure.ac: * pdf/ev-poppler.cc: (pdf_print_context_free), (pdf_document_file_exporter_begin), (pdf_document_file_exporter_do_page): Make cairo-pdf depedency optional.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2e431cf..8d17081 100644
--- a/configure.ac
+++ b/configure.ac
@@ -206,6 +206,11 @@ if test "x$enable_pdf" = "xyes"; then
LIBS="$LIBS $FRONTEND_LIBS"
AC_CHECK_FUNCS(poppler_page_render)
LIBS=$evince_save_LIBS
+
+ PKG_CHECK_MODULES(CAIRO_PDF, cairo-pdf, enable_cairo_pdf=yes, enable_cairo_pdf=no)
+ if test x$enable_cairo_pdf == xyes; then
+ AC_DEFINE([HAVE_CAIRO_PDF], [1], [defined if cairo-pdf is available])
+ fi
else
AC_MSG_WARN("PDF support is disabled since poppler-glib library version $POPPLER_REQUIRED or newer not found")
fi