Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/cut-n-paste/recent-files/Makefile.am
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <marco@src.gnome.org>2004-12-21 17:41:03 (GMT)
committer Marco Pesenti Gritti <marco@src.gnome.org>2004-12-21 17:41:03 (GMT)
commit69d92c409d333e5dd9cc82537c0834b201487c60 (patch)
treee982b034261d7c3c24992497e0a885e3d719ec0a /cut-n-paste/recent-files/Makefile.am
parent4c2778e5714bbd5ae60e74133d1482acf162e719 (diff)
Initial revision
Diffstat (limited to 'cut-n-paste/recent-files/Makefile.am')
-rw-r--r--cut-n-paste/recent-files/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/cut-n-paste/recent-files/Makefile.am b/cut-n-paste/recent-files/Makefile.am
new file mode 100644
index 0000000..c3b3dbd
--- /dev/null
+++ b/cut-n-paste/recent-files/Makefile.am
@@ -0,0 +1,32 @@
+NULL =
+
+INCLUDES = \
+ $(RECENT_FILES_CFLAGS) \
+ $(NULL)
+
+# Uses the deprecated GnomeIconTheme
+# $(EVINCE_DISABLE_DEPRECATED)
+
+EGG_FILES = \
+ egg-recent-model.c \
+ egg-recent-model.h \
+ egg-recent-item.c \
+ egg-recent-item.h \
+ egg-recent-view.c \
+ egg-recent-view.h \
+ egg-recent-view-bonobo.c \
+ egg-recent-view-bonobo.h \
+ egg-recent-view-gtk.c \
+ egg-recent-view-gtk.h \
+ egg-recent-util.c \
+ egg-recent-util.h
+
+noinst_LIBRARIES = librecent.a
+
+librecent_a_SOURCES = $(EGG_FILES)
+
+EXTRA_DIST = update-from-egg.sh
+
+EGGDIR=$(srcdir)/../../../libegg/libegg/recent-files
+regenerate-built-sources:
+ EGGFILES="$(EGG_FILES)" EGGDIR="$(EGGDIR)" $(srcdir)/update-from-egg.sh