Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/cut-n-paste/smclient/Makefile.am
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2009-02-05 09:44:50 (GMT)
committer Carlos Garcia Campos <carlosgc@src.gnome.org>2009-02-05 09:44:50 (GMT)
commit841369ba5c77e58a6fa19723b33d04720a7d4fec (patch)
tree1c50e5522fdb8994fe3a203c3fe29d5c6843bc2b /cut-n-paste/smclient/Makefile.am
parentee88daeea5519ca669244684877effbcea42fb56 (diff)
Make session manager code compile for w32. These changes have been taken
2009-02-05 Carlos Garcia Campos <carlosgc@gnome.org> * configure.ac: * cut-n-paste/smclient/Makefile.am: * cut-n-paste/smclient/eggdesktopfile.c: * cut-n-paste/smclient/eggsmclient-win32.c: * shell/main.c: Make session manager code compile for w32. These changes have been taken from upstream libegg. Based on patch by Hib Eris. See bug #339172. svn path=/trunk/; revision=3416
Diffstat (limited to 'cut-n-paste/smclient/Makefile.am')
-rw-r--r--cut-n-paste/smclient/Makefile.am26
1 files changed, 21 insertions, 5 deletions
diff --git a/cut-n-paste/smclient/Makefile.am b/cut-n-paste/smclient/Makefile.am
index c4ed73a..7cc76bc 100644
--- a/cut-n-paste/smclient/Makefile.am
+++ b/cut-n-paste/smclient/Makefile.am
@@ -1,20 +1,36 @@
noinst_LTLIBRARIES = libsmclient.la
-libsmclient_la_SOURCES = \
+if PLATFORM_WIN32
+platform_sources = eggsmclient-win32.c
+else
+platform_libs = -lSM -lICE
+platform_sources = \
+ eggsmclient-xsmp.c \
eggdesktopfile.c \
- eggdesktopfile.h \
+ eggdesktopfile.h
+platform_defines = -DEGG_SM_CLIENT_BACKEND_XSMP
+endif
+
+libsmclient_la_SOURCES = \
eggsmclient.c \
eggsmclient.h \
eggsmclient-private.h \
- eggsmclient-xsmp.c
+ $(platform_sources)
libsmclient_la_CFLAGS = \
-DG_LOG_DOMAIN=\""EggSMClient"\" \
- -DEGG_SM_CLIENT_BACKEND_XSMP \
+ $(platform_defines) \
$(SMCLIENT_CFLAGS) \
$(WARNING_CFLAGS) \
$(DISABLE_DEPRECATED)
libsmclient_la_LIBADD = \
$(SMCLIENT_LIBS) \
- -lSM -lICE
+ $(platform_libs)
+
+EXTRA_DIST = \
+ eggsmclient-win32.c \
+ eggsmclient-xsmp.c \
+ eggdesktopfile.c \
+ eggdesktopfile.h
+