Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/cut-n-paste/smclient/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@gnome.org>2009-06-14 13:29:58 (GMT)
committer Christian Persch <chpe@gnome.org>2009-06-14 13:29:58 (GMT)
commitcc1b933e22ffa0d03e99baed6ee3c693f8272013 (patch)
tree2517e1a5af416de4c1b9349ebf32da4e530b5280 /cut-n-paste/smclient/Makefile.am
parentd8d96e904debe9cdf00b75bacb1b268118ce21b3 (diff)
Only use eggdesktopfile for the xsmp backend
Diffstat (limited to 'cut-n-paste/smclient/Makefile.am')
-rw-r--r--cut-n-paste/smclient/Makefile.am16
1 files changed, 9 insertions, 7 deletions
diff --git a/cut-n-paste/smclient/Makefile.am b/cut-n-paste/smclient/Makefile.am
index cbf5f35..d85c03a 100644
--- a/cut-n-paste/smclient/Makefile.am
+++ b/cut-n-paste/smclient/Makefile.am
@@ -4,12 +4,10 @@ NULL =
if WITH_SMCLIENT
libsmclient_la_SOURCES = \
- eggdesktopfile.c \
- eggdesktopfile.h \
- eggsmclient.c \
- eggsmclient.h \
- eggsmclient-private.h \
- $(NULL)
+ eggsmclient.c \
+ eggsmclient.h \
+ eggsmclient-private.h \
+ $(NULL)
libsmclient_la_CPPFLAGS = \
-DG_LOG_DOMAIN=\""EggSMClient"\" \
@@ -25,7 +23,11 @@ libsmclient_la_LIBADD = \
$(SMCLIENT_LIBS)
if WITH_SMCLIENT_XSMP
-libsmclient_la_SOURCES += eggsmclient-xsmp.c
+libsmclient_la_SOURCES += \
+ eggdesktopfile.c \
+ eggdesktopfile.h \
+ eggsmclient-xsmp.c
+ $(NULL)
libsmclient_la_CPPFLAGS += -DEGG_SM_CLIENT_BACKEND_XSMP
endif
if WITH_SMCLIENT_WIN32