Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorNickolay V. Shmyrev <nshmyrev@src.gnome.org>2006-05-02 18:55:10 (GMT)
committer Nickolay V. Shmyrev <nshmyrev@src.gnome.org>2006-05-02 18:55:10 (GMT)
commitc9c1e2212e37fb03d5e4ce4192cfe3f8a7515c5c (patch)
tree822213156a34cfbce9fe9af770e04e6ad6695a21 /data/Makefile.am
parent70693deccf54d178c25d7f89c1b2d4a51fa5316f (diff)
Evince use it's own icon. Fix for the bug #313392.
* data/Makefile.am: * data/evince.png: * data/evince-16.png: * data/evince-22.png: * data/evince.svg: * shell/main.c: (main): Evince use it's own icon. Fix for the bug #313392. * shell/ev-window.c: (fullscreen_timeout_cb), (fullscreen_set_timeout), (fullscreen_clear_timeout), (ev_window_cmd_help_about), (ev_window_dispose): Simplify fullscreen timeout code.
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am25
1 files changed, 24 insertions, 1 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index d7d6daf..39835b3 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -26,6 +26,16 @@ schema_in_files = evince.schemas.in
schemadir = $(GCONF_SCHEMA_FILE_DIR)
schema_DATA = $(schema_in_files:.schemas.in=.schemas)
+icon_16dir = $(datadir)/icons/hicolor/16x16/apps
+icon_16_DATA = evince-16.png
+icon_22dir = $(datadir)/icons/hicolor/22x22/apps
+icon_22_DATA = evince-22.png
+icondir = $(datadir)/icons/hicolor/48x48/apps
+icon_DATA = evince.png
+svgicondir = $(datadir)/icons/hicolor/scalable/apps
+svgicon_DATA = evince.svg
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+
install-data-local:
if GCONF_SCHEMAS_INSTALL
if test -z "$(DESTDIR)" ; then \
@@ -34,14 +44,27 @@ if GCONF_SCHEMAS_INSTALL
done \
fi
endif
+ if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi
EXTRA_DIST = \
$(glade_DATA) \
$(ui_DATA) \
$(DESKTOP_IN_FILES) \
$(schema_in_files) \
- $(NULL)
+ $(icon_16_DATA) \
+ $(icon_22_DATA) \
+ $(icon_DATA) \
+ $(svgicon_DATA) \
+ $(NULL)
DISTCLEANFILES = \
$(DESKTOP_FILES) \
$(schema_DATA)
+
+