Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorJonathan Blandford <jrb@redhat.com>2005-01-19 06:12:27 (GMT)
committer Jonathan Blandford <jrb@src.gnome.org>2005-01-19 06:12:27 (GMT)
commit53d25856dc1f8997ce4d142486e2c720fe0e2100 (patch)
tree48cf5f88b7f713c7d7bde087cdda671ee4118273 /data/Makefile.am
parenta6a2ea2c622e2df3a49ab2d63f6028dec5712e50 (diff)
Add initial support for password-supported dialogs. This could be a lot
Wed Jan 19 01:10:57 2005 Jonathan Blandford <jrb@redhat.com> * backend/Makefile.am: * backend/ev-document-links.h: * backend/ev-document-security.c: (ev_document_security_get_type), (ev_document_security_has_document_security), (ev_document_security_set_password): * backend/ev-document-security.h: * backend/ev-document.c: (ev_document_error_quark): * backend/ev-document.h: * data/Makefile.am: * data/evince-password.glade: * pdf/xpdf/pdf-document.cc: * shell/Makefile.am: * shell/ev-password.c: (ev_password_set_bad_password_label), (ev_window_password_entry_changed_cb), (ev_password_dialog_new), (ev_password_dialog_get_password), (ev_password_dialog_set_bad_pass): * shell/ev-password.h: * shell/ev-window.c: (ev_window_get_attribute), (ev_window_set_property), (update_action_sensitivity), (ev_window_is_empty), (mime_type_supported_by_gdk_pixbuf), (ev_window_setup_document), (ev_window_get_password), (ev_window_open), (ev_window_cmd_save_as), (using_postscript_printer), (ev_window_print), (find_not_supported_dialog), (ev_window_cmd_edit_find), (update_fullscreen_popup), (ev_window_fullscreen), (ev_window_unfullscreen), (ev_window_cmd_view_fullscreen), (ev_window_focus_out_cb), (ev_window_cmd_help_about), (menu_item_select_cb), (find_bar_search_changed_cb), (ev_window_dispose), (ev_window_init): Add initial support for password-supported dialogs. This could be a lot cooler, but it'll do for now.
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index e543c3b..f1ca4b9 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -5,6 +5,11 @@ ui_DATA = \
evince-ui.xml \
$(NULL)
+gladedir = $(pkgdatadir)
+glade_DATA = \
+ evince-password.glade \
+ $(NULL)
+
stockdir = $(datadir)/pixmaps/evince
stock_DATA = \
ev-stock-zoom-fit-width.png \
@@ -12,5 +17,6 @@ stock_DATA = \
EXTRA_DIST = \
$(stock_DATA) \
+ $(glade_DATA) \
$(ui_DATA) \
$(NULL)