Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2010-05-22 08:34:12 (GMT)
committer Carlos Garcia Campos <carlosgc@gnome.org>2010-05-22 08:38:05 (GMT)
commitc71cb3c049f191734d90cd144cd5ec8920c02abe (patch)
tree152d9ef2368814d0cd9a8f1f7862d95eaac18cfd /data/Makefile.am
parent985f7016929bae86f89e63fc2b7b56145fbd0382 (diff)
[shell] Do not use the gconf gsettings backend any more
- rename keys to follow gsettings name restrictions (s/_/-/) - remove the hardcoding of the gconf backend - use new gsettings macros as they have changed in glib 2.25.6 Based on patch by Matthias Clasen, see bug #619335.
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am19
1 files changed, 8 insertions, 11 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index feb5230..31fceaa 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -50,19 +50,16 @@ endif
#
# GSettings schema
#
-
-# gsettingsschemadir and gschema_compile are defined by the GLIB_GSETTINGS
-# macro in configure.ac
gsettingsschema_in_files = org.gnome.Evince.gschema.xml.in
-gsettingsschema_DATA = $(gsettingsschema_in_files:.xml.in=.xml)
+# gsettings_SCHEMAS is a list of all the schemas you want to install
+gsettings_SCHEMAS = $(gsettingsschema_in_files:.xml.in=.xml)
+
+.PRECIOUS: $(gsettings_SCHEMAS)
+
@INTLTOOL_XML_NOMERGE_RULE@
-# This rule will check your schemas for validity before installation
-# Uncomment when porting is done
-# GSETTINGS_CHECK_RULE
-if GSETTINGS_SCHEMAS_INSTALL
-install-data-hook:
- $(AM_V_GEN) $(GLIB_COMPILE_SCHEMAS) --allow-any-name $(DESTDIR)$(gsettingsschemadir) --targetdir=$(DESTDIR)$(gsettingsschemadir)
-endif
+
+# include the appropriate makefile rules for schema handling
+@GSETTINGS_RULES@
#
# GTK icon cache