Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/help/reference/libdocument/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@gnome.org>2010-02-04 15:14:56 (GMT)
committer Christian Persch <chpe@gnome.org>2010-02-04 19:00:52 (GMT)
commit0ce9b3563b591c5fe980bcf47108a3f1b6dc6a85 (patch)
tree1e10792449cb3a8954fafb1bf59854f99fd0fa7f /help/reference/libdocument/Makefile.am
parent1ca3727892193af6592f7ef4dd8ed058f9a47b2b (diff)
[docs] Modernise API docs
Use no-tmpl gtk-doc option. Use xi:include, add index and object hierarchy, etc.
Diffstat (limited to 'help/reference/libdocument/Makefile.am')
-rw-r--r--help/reference/libdocument/Makefile.am84
1 files changed, 57 insertions, 27 deletions
diff --git a/help/reference/libdocument/Makefile.am b/help/reference/libdocument/Makefile.am
index ad4bc35..03dcf52 100644
--- a/help/reference/libdocument/Makefile.am
+++ b/help/reference/libdocument/Makefile.am
@@ -1,7 +1,5 @@
-## Process this file with automake to produce Makefile.in
-
-# We require automake 1.6 at least.
-AUTOMAKE_OPTIONS = 1.6
+# We require automake 1.10 for $(abs_builddir)
+AUTOMAKE_OPTIONS = 1.10
# This is a blank Makefile.am for using gtk-doc.
# Copy this to your project's API docs directory and modify the variables to
@@ -9,71 +7,91 @@ AUTOMAKE_OPTIONS = 1.6
# of using the various options.
# The name of the module, e.g. 'glib'.
-DOC_MODULE=libevdocument
+DOC_MODULE = libevdocument
+
+# Uncomment for versioned docs and specify the version of the module, e.g. '2'.
+DOC_MODULE_VERSION = $(EV_API_VERSION)
+
# The top-level SGML file. You can change this if you want to.
-DOC_MAIN_SGML_FILE=$(DOC_MODULE)-docs.sgml
+DOC_MAIN_SGML_FILE = $(DOC_MODULE)-docs.xml
# The directory containing the source code. Relative to $(srcdir).
# gtk-doc will search all .c & .h files beneath here for inline comments
# documenting the functions and macros.
# e.g. DOC_SOURCE_DIR=../../../gtk
-DOC_SOURCE_DIR=../../../libdocument
+DOC_SOURCE_DIR = ../../../libdocument
# Extra options to pass to gtkdoc-scangobj. Not normally needed.
-SCANGOBJ_OPTIONS=
+SCANGOBJ_OPTIONS =
# Extra options to supply to gtkdoc-scan.
-# e.g. SCAN_OPTIONS=--deprecated-guards="GTK_DISABLE_DEPRECATED"
-SCAN_OPTIONS=
+# e.g. SCAN_OPTIONS=--deprecated-guards="GTK_DISABLE_DEPRECATED"
+SCAN_OPTIONS =
# Extra options to supply to gtkdoc-mkdb.
# e.g. MKDB_OPTIONS=--sgml-mode --output-format=xml
-MKDB_OPTIONS=--sgml-mode --output-format=xml
+MKDB_OPTIONS = --sgml-mode --output-format=xml --name-space=ev
# Extra options to supply to gtkdoc-mktmpl
# e.g. MKTMPL_OPTIONS=--only-section-tmpl
-MKTMPL_OPTIONS=
+MKTMPL_OPTIONS =
+# Extra options to supply to gtkdoc-mkhtml
# Add the builddir to the HTML path so that version.xml is found
-MKHTML_OPTIONS=--path="$(abs_builddir)"
+MKHTML_OPTIONS = --path="$(abs_builddir)"
# Extra options to supply to gtkdoc-fixref. Not normally needed.
# e.g. FIXXREF_OPTIONS=--extra-dir=../gdk-pixbuf/html --extra-dir=../gdk/html
-FIXXREF_OPTIONS=
+FIXXREF_OPTIONS = \
+ --extra-dir=$(GLIB_PREFIX)/share/gtk-doc/html/glib \
+ --extra-dir=$(GLIB_PREFIX)/share/gtk-doc/html/gio \
+ --extra-dir=$(GTK_PREFIX)/share/gtk-doc/html/gdk \
+ --extra-dir=$(GTK_PREFIX)/share/gtk-doc/html/gdk-pixbuf \
+ --extra-dir=$(GTK_PREFIX)/share/gtk-doc/html/gtk
# Used for dependencies. The docs will be rebuilt if any of these change.
# e.g. HFILE_GLOB=$(top_srcdir)/gtk/*.h
# e.g. CFILE_GLOB=$(top_srcdir)/gtk/*.c
-HFILE_GLOB=$(top_srcdir)/libdocument/*.h
-CFILE_GLOB=$(top_srcdir)/libdocument/*.c
+HFILE_GLOB = \
+ $(top_srcdir)/libdocument/*.h \
+ $(top_builddir)/libdocument/*.h
+
+CFILE_GLOB = \
+ $(top_srcdir)/libdocument/*.c
+
+# Extra header to include when scanning, which are not under DOC_SOURCE_DIR
+# e.g. EXTRA_HFILES=$(top_srcdir}/contrib/extra.h
+# EXTRA_HFILES = $(top_builddir)/evdocument/ev-version.h
+EXTRA_HFILES =
-# Header files to ignore when scanning.
+# Header files to ignore when scanning. Use base file name, no paths
# e.g. IGNORE_HFILES=gtkdebug.h gtkintl.h
-IGNORE_HFILES= \
- ev-debug.h \
+IGNORE_HFILES = \
+ config.h \
+ ev-debug.h \
ev-module.h
# Images to copy into HTML directory.
# e.g. HTML_IMAGES=$(top_srcdir)/gtk/stock-icons/stock_about_24.png
-HTML_IMAGES=
+HTML_IMAGES =
# Extra SGML files that are included by $(DOC_MAIN_SGML_FILE).
# e.g. content_files=running.sgml building.sgml changes-2.0.sgml
-content_files= \
- version.xml
+content_files = \
+ version.xml
# SGML files where gtk-doc abbrevations (#GtkWidget) are expanded
# These files must be listed here *and* in content_files
# e.g. expand_content_files=running.sgml
-expand_content_files=
+expand_content_files =
# CFLAGS and LDFLAGS for compiling gtkdoc-scangobj with your library.
# Only needed if you are using gtkdoc-scangobj to dynamically query widget
# signals and properties.
-# e.g. INCLUDES=-I$(top_srcdir) -I$(top_builddir) $(GTK_DEBUG_FLAGS)
+# e.g. GTKDOC_CFLAGS=-I$(top_srcdir) -I$(top_builddir) $(GTK_DEBUG_FLAGS)
# e.g. GTKDOC_LIBS=$(top_builddir)/gtk/$(gtktargetlib)
-INCLUDES= \
+GTKDOC_CFLAGS = \
-I$(top_srcdir) \
-I$(top_builddir) \
-I$(top_srcdir)/libdocument \
@@ -88,7 +106,7 @@ INCLUDES= \
$(WARN_CFLAGS) \
$(DISABLE_DEPRECATED)
-GTKDOC_LIBS= \
+GTKDOC_LIBS = \
$(top_builddir)/libdocument/libevdocument.la \
$(LIBDOCUMENT_LIBS)
@@ -97,6 +115,18 @@ include $(top_srcdir)/gtk-doc.make
# Other files to distribute
# e.g. EXTRA_DIST += version.xml.in
-EXTRA_DIST += version.xml.in
+EXTRA_DIST += \
+ version.xml.in
+
+# Files not to distribute
+# for --rebuild-types in $(SCAN_OPTIONS), e.g. $(DOC_MODULE).types
+# for --rebuild-sections in $(SCAN_OPTIONS) e.g. $(DOC_MODULE)-sections.txt
+#DISTCLEANFILES +=
+
+# Comment this out if you want your docs-status tested during 'make check'
+if ENABLE_GTK_DOC
+#TESTS_ENVIRONMENT = cd $(srcsrc) &&
+#TESTS = $(GTKDOC_CHECK)
+endif
-include $(top_srcdir)/git.mk