Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <marco@gnome.org>2005-02-07 21:11:11 (GMT)
committer Marco Pesenti Gritti <marco@src.gnome.org>2005-02-07 21:11:11 (GMT)
commit16ebda50ec3b3ab96d9bbc3c8e8522b269ef1191 (patch)
tree9ce47e72252a664162bf858188190b26114a737e /lib/Makefile.am
parentc27987b5463e16a8a860e643db2091bbb1ce1628 (diff)
Add debugging helpers
2005-02-07 Marco Pesenti Gritti <marco@gnome.org> * Makefile.am: * configure.ac: * doc/debugging.txt: * lib/.cvsignore: * lib/Makefile.am: * lib/ev-debug.c: (log_module), (trap_handler), (ev_debug_init), (ev_profiler_new), (ev_should_profile), (ev_profiler_dump), (ev_profiler_free), (ev_profiler_start), (ev_profiler_stop): * lib/ev-debug.h: Add debugging helpers * ps/Makefile.am: * ps/ps-document.c: (set_up_page), (start_interpreter), (stop_interpreter), (document_load), (ps_document_next_page), (ps_document_goto_page), (ps_document_set_page_size), (ps_document_widget_event), (ps_document_render): * shell/Makefile.am: * shell/ev-view.c: (expose_bin_window): * shell/main.c: (main): Add some logs
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
new file mode 100644
index 0000000..9a3bd51
--- /dev/null
+++ b/lib/Makefile.am
@@ -0,0 +1,15 @@
+NULL=
+
+INCLUDES= \
+ -DEVINCE_UIDIR=\"$(pkgdatadir)\" \
+ -DGNOMELOCALEDIR=\"$(datadir)/locale\" \
+ $(SHELL_CFLAGS) \
+ $(EVINCE_DISABLE_DEPRECATED) \
+ $(NULL)
+
+noinst_LTLIBRARIES = libev.la
+
+libev_la_SOURCES= \
+ ev-debug.c \
+ ev-debug.h \
+ $(NULL)