Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/libdocument/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@src.gnome.org>2009-01-21 16:58:27 (GMT)
committer Christian Persch <chpe@src.gnome.org>2009-01-21 16:58:27 (GMT)
commit7d10821fa9ae7cde776bcefb9278ac0371212045 (patch)
treed25f4990415ffb882cfd3f5da742af632952f5fb /libdocument/Makefile.am
parent83f94c1e5f748c72cde600ddd09e8cc74aa9701d (diff)
Bug 568229 – library needs libtool versioning
svn path=/trunk/; revision=3373
Diffstat (limited to 'libdocument/Makefile.am')
-rw-r--r--libdocument/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/libdocument/Makefile.am b/libdocument/Makefile.am
index c08f5a8..a44ed64 100644
--- a/libdocument/Makefile.am
+++ b/libdocument/Makefile.am
@@ -1,4 +1,5 @@
INCLUDES= \
+ -DG_LOG_DOMAIN=\"EvDocument\" \
-DEVINCE_UIDIR=\"$(pkgdatadir)\" \
-DGNOMELOCALEDIR=\"$(datadir)/locale\" \
-DEV_BACKENDSDIR=\"$(libdir)/evince/backends\" \
@@ -8,7 +9,11 @@ INCLUDES= \
lib_LTLIBRARIES = libevbackend.la
-libevbackend_la_LDFLAGS = -export-dynamic
+libevbackend_la_LDFLAGS = \
+ -version-info $(EV_BACKEND_LT_VERSION_INFO) \
+ -export-symbols-regex "^ev_*" \
+ $(AM_LDFLAGS)
+
libevbackend_la_LIBADD = $(LIBDOCUMENT_LIBS)
NOINST_H_FILES = \