Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/libdocument/Makefile.am
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2007-12-28 18:13:32 (GMT)
committer Carlos Garcia Campos <carlosgc@src.gnome.org>2007-12-28 18:13:32 (GMT)
commit31e16bd8f386dc292e60489d4a17227804bdc2e6 (patch)
tree84a81ef8fa45a24351f9e8f2c0e5f2eeb20064c2 /libdocument/Makefile.am
parent8fd7569d7f146b1b21365d5afcfb7795756e544f (diff)
Plugin system for backends. Fixes bug #351348.
2007-12-28 Carlos Garcia Campos <carlosgc@gnome.org> * configure.ac: * Makefile.am: * po/POTFILES.in: * backend/comics/Makefile.am: * backend/comics/comics-document.[ch]: * backend/comics/comicsdocument.evince-backend.in: * backend/djvu/Makefile.am: * backend/djvu/djvu-document.[ch]: * backend/djvu/djvudocument.evince-backend.in: * backend/dvi/Makefile.am: * backend/dvi/dvi-document.[c]: * backend/dvi/dvidocument.evince-backend.in: * backend/impress/Makefile.am: * backend/impress/impress-document.[ch]: * backend/impress/impressdocument.evince-backend.in: * backend/pdf/Makefile.am: * backend/pdf/ev-poppler.cc: * backend/pdf/ev-poppler.h: * backend/pdf/pdfdocument.evince-backend.in: * backend/pixbuf/Makefile.am: * backend/pixbuf/pixbuf-document.[ch]: * backend/pixbuf/pixbufdocument.evince-backend.in: * backend/ps/Makefile.am: * backend/ps/ev-spectre.[ch]: * backend/ps/ps-document.[ch]: * backend/ps/psdocument.evince-backend.in: * backend/tiff/Makefile.am: * backend/tiff/tiff-document.[ch]: * backend/tiff/tiffdocument.evince-backend.in: * libdocument/Makefile.am: * libdocument/ev-backends-manager.[ch]: * libdocument/ev-module.[ch]: * libdocument/ev-document.h: * libdocument/ev-document-factory.[ch]: (gdk_pixbuf_mime_type_list), (mime_type_supported_by_gdk_pixbuf), (get_compression_from_mime_type), (get_document_from_uri), (ev_document_factory_get_document), (file_filter_add_mime_types), (ev_document_factory_add_filters): * shell/Makefile.am: * shell/ev-window-title.c: (get_filename_from_uri): * shell/main.c: (main): * thumbnailer/Makefile.am: * thumbnailer/evince-thumbnailer.c: (main): Plugin system for backends. Fixes bug #351348. svn path=/trunk/; revision=2786
Diffstat (limited to 'libdocument/Makefile.am')
-rw-r--r--libdocument/Makefile.am131
1 files changed, 48 insertions, 83 deletions
diff --git a/libdocument/Makefile.am b/libdocument/Makefile.am
index f96d019..d6e0c56 100644
--- a/libdocument/Makefile.am
+++ b/libdocument/Makefile.am
@@ -1,109 +1,77 @@
-INCLUDES= \
- -DEVINCE_UIDIR=\"$(pkgdatadir)\" \
- -DGNOMELOCALEDIR=\"$(datadir)/locale\" \
- -I$(top_srcdir)/backend/pdf \
- -I$(top_srcdir)/backend/pixbuf \
- -I$(top_srcdir)/backend/tiff \
- -I$(top_srcdir)/backend/ps \
- -I$(top_srcdir)/backend/djvu \
- -I$(top_srcdir)/backend/dvi \
- -I$(top_srcdir)/backend/impress \
- -I$(top_srcdir)/backend/comics \
- $(BACKEND_CFLAGS) \
- $(WARN_CFLAGS) \
+INCLUDES= \
+ -DEVINCE_UIDIR=\"$(pkgdatadir)\" \
+ -DGNOMELOCALEDIR=\"$(datadir)/locale\" \
+ -DEV_BACKENDSDIR=\"$(libdir)/evince/backends\" \
+ $(LIB_CFLAGS) \
+ $(WARN_CFLAGS) \
$(DISABLE_DEPRECATED)
-noinst_LTLIBRARIES = libevbackend.la
+lib_LTLIBRARIES = libevbackend.la
+
+libevbackend_la_LDFLAGS = -export-dynamic
+libevbackend_la_LIBADD = $(LIB_LIBS)
+
+NOINST_H_FILES = \
+ ev-backend-marshalers.h \
+ ev-backends-manager.h \
+ ev-document-factory.h \
+ ev-module.h
+
+INST_H_FILES = \
+ ev-async-renderer.h \
+ ev-attachment.h \
+ ev-document-find.h \
+ ev-document-fonts.h \
+ ev-document-forms.h \
+ ev-document.h \
+ ev-document-images.h \
+ ev-document-info.h \
+ ev-document-links.h \
+ ev-document-misc.h \
+ ev-document-security.h \
+ ev-document-thumbnails.h \
+ ev-document-transition.h \
+ ev-file-exporter.h \
+ ev-file-helpers.h \
+ ev-form-field.h \
+ ev-image.h \
+ ev-link-action.h \
+ ev-link-dest.h \
+ ev-link.h \
+ ev-render-context.h \
+ ev-selection.h
+
+headerdir = $(prefix)/include/evince-@EV_API_VERSION@/evince
+header_DATA = $(INST_H_FILES)
libevbackend_la_SOURCES= \
ev-async-renderer.c \
- ev-async-renderer.h \
ev-attachment.c \
- ev-attachment.h \
+ ev-backends-manager.c \
ev-backend-marshal.c \
ev-link.c \
- ev-link.h \
ev-link-action.c \
- ev-link-action.h \
ev-link-dest.c \
- ev-link-dest.h \
ev-image.c \
- ev-image.h \
ev-document.c \
- ev-document.h \
ev-document-factory.c \
- ev-document-factory.h \
ev-document-thumbnails.c \
- ev-document-thumbnails.h \
ev-document-fonts.c \
- ev-document-fonts.h \
ev-document-links.c \
- ev-document-links.h \
ev-document-images.c \
- ev-document-images.h \
ev-document-security.c \
- ev-document-security.h \
ev-document-find.c \
- ev-document-find.h \
- ev-document-info.h \
- ev-document-transition.h \
ev-document-transition.c \
- ev-document-forms.h \
ev-document-forms.c \
- ev-form-field.h \
ev-form-field.c \
ev-file-exporter.c \
- ev-file-exporter.h \
ev-file-helpers.c \
- ev-file-helpers.h \
- ev-render-context.h \
+ ev-module.c \
ev-render-context.c \
- ev-selection.h \
ev-selection.c \
- ev-document-misc.h \
- ev-document-misc.c
-
-libevbackend_la_LIBADD =
-
-if ENABLE_PDF
-libevbackend_la_LIBADD += \
- $(top_builddir)/backend/pdf/libpdfdocument.la
-endif
-
-if ENABLE_PS
-libevbackend_la_LIBADD += \
- $(top_builddir)/backend/ps/libpsdocument.la
-endif
-
-if ENABLE_PIXBUF
-libevbackend_la_LIBADD += \
- $(top_builddir)/backend/pixbuf/libpixbufdocument.la
-endif
-
-if ENABLE_DJVU
-libevbackend_la_LIBADD += \
- $(top_builddir)/backend/djvu/libgtkdjvu.la
-endif
-
-if ENABLE_TIFF
-libevbackend_la_LIBADD += \
- $(top_builddir)/backend/tiff/libtiffdocument.la
-endif
-
-if ENABLE_DVI
-libevbackend_la_LIBADD += \
- $(top_builddir)/backend/dvi/libgtkdvi.la
-endif
-
-if ENABLE_COMICS
-libevbackend_la_LIBADD += \
- $(top_builddir)/backend/comics/libcomicsdocument.la
-endif
-
-if ENABLE_IMPRESS
-libevbackend_la_LIBADD += \
- $(top_builddir)/backend/impress/libimpressdocument.la
-endif
+ ev-document-misc.c \
+ $(NOINST_H_FILES) \
+ $(INST_H_FILES)
BUILT_SOURCES= \
ev-backend-marshalers.h \
@@ -119,8 +87,5 @@ ev-backend-marshalers.c: ev-backend-marshalers.list
ev-backend-marshal.c: ev-backend-marshalers.h ev-backend-marshalers.c
-noinst_HEADERS = \
- ev-backend-marshalers.h
-
EXTRA_DIST= \
ev-backend-marshalers.list