Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/libdocument/Makefile.am
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2009-05-12 17:12:16 (GMT)
committer Carlos Garcia Campos <carlosgc@gnome.org>2009-05-12 17:12:16 (GMT)
commit796028ef614e6cfbdfba67927fe9696efaac1269 (patch)
treef1390730bc11efc56c7b928725db81c809951a5c /libdocument/Makefile.am
parentb1e91476f3aa8b27086242c915a4f8b1c9ba1e7c (diff)
[build] Use shave to improve build log readability
Diffstat (limited to 'libdocument/Makefile.am')
-rw-r--r--libdocument/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/libdocument/Makefile.am b/libdocument/Makefile.am
index e6ccb51..1597c72 100644
--- a/libdocument/Makefile.am
+++ b/libdocument/Makefile.am
@@ -1,3 +1,5 @@
+QUIET_GEN = $(Q:@=@echo ' GEN '$@;)
+
lib_LTLIBRARIES = libevdocument.la
NOINST_H_FILES = \
@@ -111,13 +113,13 @@ ev-document-type-builtins.h: stamp-ev-document-type-builtins.h
@true
stamp-ev-document-type-builtins.h: ev-document-type-builtins.h.template $(INST_H_FILES)
- $(GLIB_MKENUMS) --template $< $(filter-out $<,$^) > xgen-etbh \
+ $(QUIET_GEN)$(GLIB_MKENUMS) --template $< $(filter-out $<,$^) > xgen-etbh \
&& (cmp -s xgen-etbh ev-document-type-builtins.h || cp xgen-etbh ev-document-type-builtins.h ) \
&& rm -f xgen-etbh \
&& echo timestamp > $(@F)
ev-document-type-builtins.c: ev-document-type-builtins.c.template $(INST_H_FILES)
- $(GLIB_MKENUMS) --template $< $(filter-out $<,$^) > xgen-etbc \
+ $(QUIET_GEN)$(GLIB_MKENUMS) --template $< $(filter-out $<,$^) > xgen-etbc \
&& (cmp -s xgen-etbc ev-document-type-builtins.c || cp xgen-etbc ev-document-type-builtins.c ) \
&& rm -f xgen-etbc