Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/libdocument/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@src.gnome.org>2009-02-08 13:11:18 (GMT)
committer Christian Persch <chpe@src.gnome.org>2009-02-08 13:11:18 (GMT)
commitdbedc68c9c3390f4f8c749daa85f685923f20e17 (patch)
treeea0148a686a68a4a0ce7ed8a97399c61e76eef85 /libdocument/Makefile.am
parentb16d94919e61b0228950073ade43ace80fb1e1b0 (diff)
Add experimental introspection support. Disabled by default; use
* configure.ac: * libdocument/Makefile.am: * libview/Makefile.am: Add experimental introspection support. Disabled by default; use --enable-introspection to enable it. Bug #569083. svn path=/trunk/; revision=3422
Diffstat (limited to 'libdocument/Makefile.am')
-rw-r--r--libdocument/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/libdocument/Makefile.am b/libdocument/Makefile.am
index 6eab585..ffbe19d 100644
--- a/libdocument/Makefile.am
+++ b/libdocument/Makefile.am
@@ -119,3 +119,46 @@ ev-document-type-builtins.c: ev-document-type-builtins.c.template $(INST_H_FILES
EXTRA_DIST = \
ev-document-type-builtins.c.template \
ev-document-type-builtins.h.template
+
+# GObject Introspection
+
+if ENABLE_INTROSPECTION
+
+EvDocument-$(EV_API_VERSION).gir: libevdocument.la Makefile $(INST_H_FILES)
+ PKG_CONFIG_PATH=$(top_builddir):$$PKG_CONFIG_PATH \
+ $(G_IR_SCANNER) -v --namespace EvDocument \
+ --add-include-path=$(srcdir) \
+ --add-include-path=. \
+ --strip-prefix=Ev \
+ --nsversion=$(EV_API_VERSION) \
+ --include=Gio-2.0 \
+ --include=Gtk-2.0 \
+ --library=evdocument \
+ --libtool="$(LIBTOOL)" \
+ --output $@ \
+ --pkg gobject-2.0 \
+ --pkg gio-2.0 \
+ --pkg gtk+-2.0 \
+ --pkg evince-document-$(EV_API_VERSION) \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ -DEVINCE_COMPILATION \
+ $(INST_H_FILES)
+
+girdir = $(GIRDIR)
+gir_DATA = EvDocument-$(EV_API_VERSION).gir
+
+typelibsdir = $(GIRTYPELIBDIR)
+typelibs_DATA = EvDocument-$(EV_API_VERSION).typelib
+
+EXTRA_DIST += $(gir_DATA)
+CLEANFILES += $(gir_DATA) $(typelibs_DATA)
+
+%.typelib: %.gir
+ LD_LIBRARY_PATH=$${LD_LIBRARY_PATH:+$$LD_LIBRARY_PATH:}. $(G_IR_COMPILER) \
+ --includedir=$(srcdir) \
+ --includedir=. \
+ $(G_IR_COMPILER_OPTS) \
+ $< -o $@
+
+endif # ENABLE_INTROSPECTION