Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/pdf/xpdf/Makefile.am
diff options
context:
space:
mode:
authorMartin Kretzschmar <mkretzschmar@src.gnome.org>2003-03-31 21:08:43 (GMT)
committer Martin Kretzschmar <mkretzschmar@src.gnome.org>2003-03-31 21:08:43 (GMT)
commit64676031423465996e83c4a685290f0c3d97a249 (patch)
treecef578bc8c300722abb3fe1693181e68895a94a7 /pdf/xpdf/Makefile.am
parent28c37dbcf87665a4ccec58bef9ef8ff0697022dd (diff)
kill traces of ltk, incorporate new sources
* xpdf/Makefile.am: kill traces of ltk, incorporate new sources * Makefile.am, configure.in: don't build the ltk subdir * ANNOUNCE, CHANGES, ChangeLog, README, aconf-dj.h, aconf-win32.h, dj_make.bat, ms_make.bat, vms_make.com: update * xpdf/LTKOutputDev.cc, xpdf/LTKOutputDev.h, xpdf/postscript.xbm, xpdf/xpdf-flip.ltk, xpdf/xpdf-ltk.h, xpdf/xpdf-top.ltk, xpdf/xpdf.ltk: remove. * xpdf/Annot.cc, xpdf/Annot.h, xpdf/Array.cc, xpdf/Array.h, xpdf/BuiltinFont.cc, xpdf/BuiltinFont.h, xpdf/BuiltinFontTables.cc, xpdf/CMap.cc, xpdf/CMap.h, xpdf/Catalog.cc, xpdf/Catalog.h, xpdf/CharCodeToUnicode.cc, xpdf/CharCodeToUnicode.h, xpdf/Decrypt.cc, xpdf/Decrypt.h, xpdf/Dict.cc, xpdf/Dict.h, xpdf/Error.cc, xpdf/Error.h, xpdf/FTFont.cc, xpdf/FTFont.h, xpdf/FontFile.cc, xpdf/FontFile.h, xpdf/Function.cc, xpdf/Function.h, xpdf/Gfx.cc, xpdf/Gfx.h, xpdf/GfxFont.cc, xpdf/GfxFont.h, xpdf/GfxState.cc, xpdf/GfxState.h, xpdf/GlobalParams.cc, xpdf/GlobalParams.h, xpdf/ImageOutputDev.cc, xpdf/ImageOutputDev.h, xpdf/Lexer.cc, xpdf/Lexer.h, xpdf/Link.cc, xpdf/Link.h, xpdf/NameToCharCode.cc, xpdf/NameToCharCode.h, xpdf/NameToUnicodeTable.h, xpdf/Object.cc, xpdf/Object.h, xpdf/OutputDev.cc, xpdf/OutputDev.h, xpdf/PBMOutputDev.cc, xpdf/PBMOutputDev.h, xpdf/PDFDoc.cc, xpdf/PDFDoc.h, xpdf/PSOutputDev.cc, xpdf/PSOutputDev.h, xpdf/PSTokenizer.cc, xpdf/PSTokenizer.h, xpdf/Page.cc, xpdf/Page.h, xpdf/Parser.cc, xpdf/Parser.h, xpdf/SFont.cc, xpdf/SFont.h, xpdf/Stream.cc, xpdf/Stream.h, xpdf/T1Font.cc, xpdf/T1Font.h, xpdf/TTFont.cc, xpdf/TTFont.h, xpdf/TextOutputDev.cc, xpdf/TextOutputDev.h, xpdf/UnicodeMap.cc, xpdf/UnicodeMap.h, xpdf/XOutputDev.cc, xpdf/XOutputDev.h, xpdf/XRef.cc, xpdf/XRef.h, xpdf/config.h, xpdf/pdffonts.cc, xpdf/pdfimages.cc, xpdf/pdfinfo.cc, xpdf/pdftopbm.cc, xpdf/pdftops.cc, xpdf/pdftotext.cc, xpdf/vms_make.com, xpdf/xpdf.cc: update. * goo/GHash.cc, goo/GHash.h, goo/GList.cc, goo/GList.h, goo/GString.cc, goo/GString.h: mostly Mac OS X gcc fixage. * doc/pdffonts.1, doc/pdffonts.cat, doc/pdffonts.hlp, doc/pdfimages.1, doc/pdfimages.cat, doc/pdfimages.hlp, doc/pdfinfo.1, doc/pdfinfo.cat, doc/pdfinfo.hlp, doc/pdftopbm.1, doc/pdftopbm.cat, doc/pdftopbm.hlp, doc/pdftops.1, doc/pdftops.cat, doc/pdftops.hlp, doc/pdftotext.1, doc/pdftotext.cat, doc/pdftotext.hlp, doc/xpdf.1, doc/xpdf.cat, doc/xpdf.hlp, doc/xpdfrc.5, doc/xpdfrc.cat, doc/xpdfrc.hlp: update docs.
Diffstat (limited to 'pdf/xpdf/Makefile.am')
-rw-r--r--pdf/xpdf/Makefile.am25
1 files changed, 17 insertions, 8 deletions
diff --git a/pdf/xpdf/Makefile.am b/pdf/xpdf/Makefile.am
index 1ab6b31..3e39038 100644
--- a/pdf/xpdf/Makefile.am
+++ b/pdf/xpdf/Makefile.am
@@ -1,7 +1,6 @@
INCLUDES = \
-I$(top_srcdir)/goo \
- -I$(top_srcdir)/ltk \
-DDATADIR=\""$(datadir)"\" \
-DGNOMELOCALEDIR=\""$(prefix)/$(DATADIRNAME)/locale"\" \
-DGNOMEICONDIR=\""$(datadir)/pixmaps"\" \
@@ -67,6 +66,8 @@ common_sources = \
GfxState.h \
GlobalParams.cc \
GlobalParams.h \
+ JBIG2Stream.cc \
+ JBIG2Stream.h \
Lexer.cc \
Lexer.h \
Link.cc \
@@ -76,10 +77,14 @@ common_sources = \
NameToUnicodeTable.h \
Object.cc \
Object.h \
+ Outline.cc \
+ Outline.h \
OutputDev.cc \
OutputDev.h \
PDFDoc.cc \
PDFDoc.h \
+ PDFDocEncoding.cc \
+ PDFDocEncoding.h \
PSTokenizer.cc \
PSTokenizer.h \
Page.cc \
@@ -152,8 +157,18 @@ gnome_pdf_viewer_LDADD = \
xpdf_SOURCES = \
$(common_sources) \
+ XPDFApp.cc \
+ XPDFApp.h \
+ XPDFCore.cc \
+ XPDFCore.h \
+ XPDFTree.cc \
+ XPDFTree.h \
+ XPDFViewer.cc \
+ XPDFViewer.h \
XOutputDev.cc \
- LTKOutputDev.cc \
+ XOutputDev.h \
+ XPixmapOutputDev.cc \
+ XPixmapOutputDev.h \
PSOutputDev.cc \
PSOutputDev.h \
xpdf.cc
@@ -161,7 +176,6 @@ xpdf_SOURCES = \
xpdf_CFLAGS = $(X_CFLAGS)
xpdf_LDADD = \
$(top_builddir)/goo/libgoo.a \
- $(top_builddir)/ltk/libltk.a \
-lXpm \
$(EXTRA_GNOME_LIBS) \
$(libpaper_LIBS)
@@ -201,11 +215,6 @@ xpdf_LDADD = \
#pdftopbm_LDADD = ../goo/libgoo.a $(EXTRA_GNOME_LIBS)
-xpdf-ltk.h: xpdf.ltk
- rm -f $@
- $(top_srcdir)/ltk/ltkbuild <xpdf.ltk >$@.new
- mv $@.new $@
-
#bitmaps =
# about.xbm
# dblLeftArrow.xbm