Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/pdf/xpdf/Makefile.am
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@redhat.com>2005-03-01 22:24:10 (GMT)
committer Kristian Høgsberg <krh@src.gnome.org>2005-03-01 22:24:10 (GMT)
commit02eb16fef45712a91e24f6471b9e2f31249c888e (patch)
treed5579258f1d7fbd5a280fb2f1b97b74004b1dea9 /pdf/xpdf/Makefile.am
parent332afee84ff4eb7df326d96f07efd6f82a87c0a2 (diff)
Use poppler instead of including xpdf source code. Poppler is a fork of
2005-03-01 Kristian Høgsberg <krh@redhat.com> Use poppler instead of including xpdf source code. Poppler is a fork of xpdf to build it as a shared library. See http://freedesktop.org/wiki/Software/poppler. * pdf/xpdf/*, pdf/goo/*, pdf/splash/*, pdf/fofi/*: Remove included xpdf fork. * pdf/Makefile.am: Build libpdfdocument.a here. * pdf/GDKSplashOutputDev.cc: * pdf/GDKSplashOutputDev.h: * pdf/GnomeVFSStream.cc: * pdf/GnomeVFSStream.h: * pdf-document.cc: * pdf-document.h: * test-gdk-output-dev.cc * Thumb.cc: * Thumb.h: Pull these files out of pdf/xpdf and adjust to compile against poppler.
Diffstat (limited to 'pdf/xpdf/Makefile.am')
-rw-r--r--pdf/xpdf/Makefile.am131
1 files changed, 0 insertions, 131 deletions
diff --git a/pdf/xpdf/Makefile.am b/pdf/xpdf/Makefile.am
deleted file mode 100644
index 4e884cc..0000000
--- a/pdf/xpdf/Makefile.am
+++ /dev/null
@@ -1,131 +0,0 @@
-INCLUDES = \
- -I$(top_srcdir) \
- -I$(top_srcdir)/backend \
- -I$(top_srcdir)/pdf \
- -I$(top_srcdir)/pdf/goo \
- -I$(top_srcdir)/pdf/fofi \
- -I$(top_srcdir)/pdf/splash \
- $(GTK_CFLAGS) \
- -DDATADIR=\""$(datadir)"\"
-
-noinst_PROGRAMS = test-gdk-output-dev
-
-noinst_LTLIBRARIES = libxpdf.la libpdfdocument.la
-
-libxpdf_la_SOURCES = \
- Annot.cc \
- Annot.h \
- Array.cc \
- Array.h \
- BaseFile.h \
- BuiltinFont.cc \
- BuiltinFont.h \
- BuiltinFontTables.cc \
- BuiltinFontTables.h \
- Catalog.cc \
- Catalog.h \
- CharCodeToUnicode.cc \
- CharCodeToUnicode.h \
- CMap.cc \
- CMap.h \
- Decrypt.cc \
- Decrypt.h \
- Dict.cc \
- Dict.h \
- Error.cc \
- Error.h \
- FontEncodingTables.cc \
- FontEncodingTables.h \
- Function.cc \
- Function.h \
- Gfx.cc \
- Gfx.h \
- GfxFont.cc \
- GfxFont.h \
- GfxState.cc \
- GfxState.h \
- GlobalParams.cc \
- GlobalParams.h \
- JArithmeticDecoder.cc \
- JArithmeticDecoder.h \
- JBIG2Stream.cc \
- JBIG2Stream.h \
- JPXStream.cc \
- JPXStream.h \
- Lexer.cc \
- Lexer.h \
- Link.cc \
- Link.h \
- NameToCharCode.cc \
- NameToCharCode.h \
- Object.cc \
- Object.h \
- Outline.cc \
- Outline.h \
- OutputDev.cc \
- OutputDev.h \
- Page.cc \
- Page.h \
- Parser.cc \
- Parser.h \
- PDFDoc.cc \
- PDFDoc.h \
- PDFDocEncoding.cc \
- PDFDocEncoding.h \
- PSTokenizer.cc \
- PSTokenizer.h \
- SplashOutputDev.cc \
- SplashOutputDev.h \
- Stream-CCITT.h \
- Stream.cc \
- Stream.h \
- Thumb.cc \
- Thumb.h \
- UnicodeMap.cc \
- UnicodeMap.h \
- UnicodeMapTables.h \
- UnicodeTypeTable.cc \
- UnicodeTypeTable.h \
- XRef.cc \
- XRef.h \
- \
- CharTypes.h \
- CompactFontTables.h \
- ErrorCodes.h \
- NameToUnicodeTable.h \
- GDKSplashOutputDev.cc \
- GDKSplashOutputDev.h \
- PSOutputDev.cc \
- PSOutputDev.h \
- TextOutputDev.cc \
- TextOutputDev.h \
- UTF8.h \
- \
- gpdf-g-switch.h
-
-# The sources at the end are put in libxpdf.a for convenience here, but are
-# conceptually part of the apps not part of the libs.
-
-test_gdk_output_dev_SOURCES = \
- test-gdk-output-dev.cc
-
-test_gdk_output_dev_LDADD = \
- libxpdf.la \
- $(top_builddir)/pdf/goo/libGoo.la \
- $(top_builddir)/pdf/fofi/libfofi.la \
- $(top_builddir)/pdf/splash/libsplash.la \
- $(top_builddir)/backend/libevbackend.la \
- $(GTK_LIBS)
-
-libpdfdocument_la_SOURCES = \
- pdf-document.cc \
- pdf-document.h
-
-libpdfdocument_la_LIBADD = \
- libxpdf.la \
- $(top_builddir)/backend/libevbackend.la \
- $(top_builddir)/pdf/goo/libGoo.la \
- $(top_builddir)/pdf/fofi/libfofi.la \
- $(top_builddir)/pdf/splash/libsplash.la
-
-EXTRA_DIST = xpdfconfig.h